summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-07-18 14:42:25 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-07-18 14:42:25 +0000
commit9c7ed65691c8b8dbf97443a1708564c8c0b95820 (patch)
tree7811f837eb46eaa4814efcf5dbda965464159a9d
parentRemove isomarkboot from ia64 archscript. (diff)
downloadgentoo-9c7ed65691c8b8dbf97443a1708564c8c0b95820.tar.gz
gentoo-9c7ed65691c8b8dbf97443a1708564c8c0b95820.tar.bz2
gentoo-9c7ed65691c8b8dbf97443a1708564c8c0b95820.zip
Add livecd/readme back to livecd-stage2 to allow overriding the default README.txt file. This is catalyst 1.1.10.5.
-rw-r--r--src/catalyst/ChangeLog8
-rw-r--r--src/catalyst/catalyst4
-rw-r--r--src/catalyst/examples/livecd-stage2_template.spec8
-rw-r--r--src/catalyst/livecd/runscript/default-runscript.sh12
-rw-r--r--src/catalyst/modules/livecd_stage2_target.py9
5 files changed, 32 insertions, 9 deletions
diff --git a/src/catalyst/ChangeLog b/src/catalyst/ChangeLog
index ae65e51ff3..b200903709 100644
--- a/src/catalyst/ChangeLog
+++ b/src/catalyst/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gentoo/src/catalyst
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo/src/catalyst/Attic/ChangeLog,v 1.198.2.109 2005/07/15 20:53:07 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo/src/catalyst/Attic/ChangeLog,v 1.198.2.110 2005/07/18 14:42:25 wolf31o2 Exp $
+
+ 18 Jul 2005; Chris Gianelloni <wolf31o2@gentoo.org> catalyst,
+ examples/livecd-stage2_template.spec,
+ livecd/runscript/default-runscript.sh, modules/livecd_stage2_target.py:
+ Add livecd/readme back to livecd-stage2 to allow overriding the default
+ README.txt file. This is catalyst 1.1.10.5.
15 Jul 2005; Chris Gianelloni <wolf31o2@gentoo.org>
livecd/runscript/ia64-archscript.sh:
diff --git a/src/catalyst/catalyst b/src/catalyst/catalyst
index 0f8609b81c..ac294bffb0 100644
--- a/src/catalyst/catalyst
+++ b/src/catalyst/catalyst
@@ -1,12 +1,12 @@
#!/usr/bin/python
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo/src/catalyst/Attic/catalyst,v 1.68.2.26 2005/07/13 00:04:53 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo/src/catalyst/Attic/catalyst,v 1.68.2.27 2005/07/18 14:42:25 wolf31o2 Exp $
import os,sys,imp,string,getopt
__maintainer__="Chris Gianelloni <wolf31o2@gentoo.org>"
-__version__="1.1.10.4"
+__version__="1.1.10.5"
conf_values={}
diff --git a/src/catalyst/examples/livecd-stage2_template.spec b/src/catalyst/examples/livecd-stage2_template.spec
index c856d61471..cce79e25b1 100644
--- a/src/catalyst/examples/livecd-stage2_template.spec
+++ b/src/catalyst/examples/livecd-stage2_template.spec
@@ -149,6 +149,14 @@ livecd/linuxrc:
# livecd/type: gentoo-release-minimal
livecd/type:
+# This is for the README.txt on the root of the CD. For Gentoo releases, we
+# use a default README.txt, and this will be used on your CD if you do not
+# provide one yourself. Since we do not use this for the official releases, it
+# is left blank below.
+# example:
+# livecd/readme:
+livecd/readme:
+
# This is for the CD's message of the day. It is not required for official
# release media, as catalyst builds a default motd when the livecd/type is set
# to one of the gentoo-* options. This setting overrides the default motd even
diff --git a/src/catalyst/livecd/runscript/default-runscript.sh b/src/catalyst/livecd/runscript/default-runscript.sh
index 1c2c762df1..b06ccff7a7 100644
--- a/src/catalyst/livecd/runscript/default-runscript.sh
+++ b/src/catalyst/livecd/runscript/default-runscript.sh
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo/src/catalyst/livecd/runscript/Attic/default-runscript.sh,v 1.25.2.8 2005/07/14 15:49:03 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo/src/catalyst/livecd/runscript/Attic/default-runscript.sh,v 1.25.2.9 2005/07/18 14:42:25 wolf31o2 Exp $
#return codes to be used by archscript
die() {
@@ -28,7 +28,7 @@ source ${clst_livecd_archscript}
# Here is where we poke in our identifier
touch ${clst_cdroot_path}/livecd
# Here we copy our nifty README.txt
-cp ${clst_sharedir}/livecd/files/README.txt ${clst_cdroot_path}
+#cp ${clst_sharedir}/livecd/files/README.txt ${clst_cdroot_path}
create_normal_loop() {
# We get genkernel-built kernels and initrds in place, create the loopback
@@ -143,6 +143,14 @@ case $1 in
cp -a ${clst_livecd_xinitrc} ${clst_chroot_path}/etc/X11/xinit/xinitrc
fi
+ # move over the readme (if applicable)
+ if [ -n "${clst_livecd_readme}" ]
+ then
+ cp -a ${clst_livecd_readme} ${clst_cdroot_path}/README.txt
+ else
+ cp ${clst_sharedir}/livecd/files/README.txt ${clst_cdroot_path}
+ fi
+
# move over the environment
cp ${clst_sharedir}/livecd/files/livecd-bashrc \
${clst_chroot_path}/root/.bashrc
diff --git a/src/catalyst/modules/livecd_stage2_target.py b/src/catalyst/modules/livecd_stage2_target.py
index 9ce757aae3..24f036b4eb 100644
--- a/src/catalyst/modules/livecd_stage2_target.py
+++ b/src/catalyst/modules/livecd_stage2_target.py
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo/src/catalyst/modules/Attic/livecd_stage2_target.py,v 1.30.2.8 2005/07/12 23:31:55 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo/src/catalyst/modules/Attic/livecd_stage2_target.py,v 1.30.2.9 2005/07/18 14:42:25 wolf31o2 Exp $
"""
Builder class for a LiveCD stage2 build.
@@ -37,10 +37,11 @@ class livecd_stage2_target(generic_stage_target):
self.valid_values.extend(self.required_values)
self.valid_values.extend(["livecd/cdtar","livecd/empty","livecd/rm",\
"livecd/unmerge","livecd/iso","livecd/gk_mainargs","livecd/type",\
- "livecd/motd","livecd/overlay","livecd/modblacklist","livecd/splash_theme",\
+ "livecd/readme","livecd/motd","livecd/overlay",\
+ "livecd/modblacklist","livecd/splash_theme","livecd/splash_type",\
"livecd/rcadd","livecd/rcdel","livecd/fsscript","livecd/xinitrc",\
- "livecd/root_overlay","livecd/devmanager","livecd/splash_type",\
- "gamecd/conf","livecd/users","livecd/linuxrc","livecd/bootargs"])
+ "livecd/root_overlay","livecd/devmanager","livecd/users",\
+ "livecd/linuxrc","livecd/bootargs","gamecd/conf"])
generic_stage_target.__init__(self,spec,addlargs)
self.set_cdroot_path()