summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-05 23:00:44 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-05 23:00:44 +0000
commitb5a76d0201e4b8ff52e098357fcebbc23b072e78 (patch)
tree112c1d1398ffeb99a88f06b6179828dadbec9471 /app-admin/watchdog
parentuse xpm from the package (diff)
downloadgentoo-2-b5a76d0201e4b8ff52e098357fcebbc23b072e78.tar.gz
gentoo-2-b5a76d0201e4b8ff52e098357fcebbc23b072e78.tar.bz2
gentoo-2-b5a76d0201e4b8ff52e098357fcebbc23b072e78.zip
stabilize
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'app-admin/watchdog')
-rw-r--r--app-admin/watchdog/watchdog-5.2.4.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/app-admin/watchdog/watchdog-5.2.4.ebuild b/app-admin/watchdog/watchdog-5.2.4.ebuild
index 99bf8fded20e..17bc895b8bed 100644
--- a/app-admin/watchdog/watchdog-5.2.4.ebuild
+++ b/app-admin/watchdog/watchdog-5.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.4.ebuild,v 1.8 2005/04/24 02:56:58 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.4.ebuild,v 1.9 2005/05/05 23:00:44 vapier Exp $
inherit eutils
@@ -10,18 +10,18 @@ SRC_URI="mirror://debian/pool/main/w/watchdog/${PN}_${PV}.orig.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~mips ppc ~x86"
+KEYWORDS="amd64 arm ~mips ppc x86"
IUSE=""
-DEPEND="virtual/libc"
+DEPEND=""
S=${WORKDIR}/${P}.orig
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-sundries.patch
- epatch ${FILESDIR}/${PV}-uclibc.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-sundries.patch
+ epatch "${FILESDIR}"/${PV}-uclibc.patch
}
src_compile() {
@@ -36,16 +36,13 @@ src_install() {
dodir /etc/watchdog
make DESTDIR="${D}" install || die
- exeinto /etc/init.d
- doexe ${FILESDIR}/watchdog
- insinto /etc/conf.d
- newins ${FILESDIR}/watchdog.conf.d watchdog
+ doinitd ${FILESDIR}/watchdog
+ newconfd ${FILESDIR}/watchdog.conf.d watchdog
}
pkg_postinst() {
einfo "To enable the start-up script run \"rc-update add watchdog boot\"."
- if [ ! -e ${ROOT}/dev/watchdog ]
- then
+ if [[ ! -e ${ROOT}/dev/watchdog ]] ; then
ewarn "No /dev/watchdog found! Make sure your kernel has watchdog support"
ewarn "compiled in or the kernel module is loaded. The watchdog service"
ewarn "will not start at boot until your kernel is configured properly."