summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-11-15 05:43:22 +0000
committerAlin Năstac <mrness@gentoo.org>2005-11-15 05:43:22 +0000
commit98becce2fbe942250d535ca66d5e0b79e4aaceac (patch)
tree0e44a5d437e06605ced5214b7f8bd5a3817792e2 /app-mobilephone/gnokii/gnokii-0.6.4.ebuild
parentrepoman: Trim trailing whitespace (diff)
downloadgentoo-2-98becce2fbe942250d535ca66d5e0b79e4aaceac.tar.gz
gentoo-2-98becce2fbe942250d535ca66d5e0b79e4aaceac.tar.bz2
gentoo-2-98becce2fbe942250d535ca66d5e0b79e4aaceac.zip
Remove obsolete versions. Mark version 0.6.8 stable on x86. Version bump (#112566).
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'app-mobilephone/gnokii/gnokii-0.6.4.ebuild')
-rw-r--r--app-mobilephone/gnokii/gnokii-0.6.4.ebuild87
1 files changed, 0 insertions, 87 deletions
diff --git a/app-mobilephone/gnokii/gnokii-0.6.4.ebuild b/app-mobilephone/gnokii/gnokii-0.6.4.ebuild
deleted file mode 100644
index 03882fe207b8..000000000000
--- a/app-mobilephone/gnokii/gnokii-0.6.4.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/gnokii-0.6.4.ebuild,v 1.3 2005/09/01 17:01:52 mrness Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="user space driver and tools for use with mobile phones"
-HOMEPAGE="http://www.gnokii.org/"
-SRC_URI="http://www.gnokii.org/download/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 hppa ia64 ~ppc ppc64 sparc x86"
-IUSE="nls X bluetooth irda sms postgres mysql"
-
-RDEPEND="X? ( =x11-libs/gtk+-1.2* )
- bluetooth? ( net-wireless/bluez-libs )
- sms? ( postgres? ( dev-db/postgresql )
- mysql? ( dev-db/mysql ) )"
-DEPEND="${RDEPEND}
- irda? ( virtual/os-headers )
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed -i -e 's:/usr/local/:/usr/:g' Docs/sample/gnokiirc && \
- epatch ${FILESDIR}/${P}-nounix98pty.patch || \
- die "something has changed in this package"
-}
-
-src_compile() {
- append-ldflags "-Wl,-z,now" #avoid QA notices
-
- econf \
- $(use_enable nls) \
- $(use_with X x) \
- --enable-security \
- || die "configure failed"
-
- emake -j1 || die "make failed"
-
- if use sms
- then
- cd ${S}/smsd
-
- if use postgres; then
- emake libpq.la || die "smsd make failed"
- elif use mysql; then
- emake libmysql.la || die "smsd make failed"
- else
- emake libfile.la || die "smsd make failed"
- fi
- fi
-}
-
-src_install() {
- einstall || die "make install failed"
-
- insinto /etc
- doins Docs/sample/gnokiirc
-
- doman Docs/man/*
- dodir /usr/share/doc/${PF}
- cp -r Docs/sample ${D}/usr/share/doc/${PF}/sample
- cp -r Docs/protocol ${D}/usr/share/doc/${PF}/protocol
- rm -rf Docs/man Docs/sample Docs/protocol
- dodoc Docs/*
-
- # only one file needs suid root to make a psuedo device
- fperms 4755 /usr/sbin/mgnokiidev
-
- if use sms; then
- cd ${S}/smsd
-
- einstall || die "smsd make install failed"
- fi
-
- insinto /usr/share/applications
- doins ${FILESDIR}/${PN}.desktop
-}
-
-pkg_postinst() {
- einfo "gnokii does not need it's own group anymore."
- einfo "Make sure the user that runs gnokii has read/write access to the device"
- einfo "which your phone is connected to. eg. chown <user> /dev/ttyS0"
-}