summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2003-12-23 16:43:53 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2003-12-23 16:43:53 +0000
commitc8cad06961b104430db5f6f0247a9a327829fe8c (patch)
tree14c5a8849dcbddfde5ed44889f528ca2863cac71 /app-vim/zoomwin/zoomwin-16.ebuild
parentanother new version out (diff)
downloadgentoo-2-c8cad06961b104430db5f6f0247a9a327829fe8c.tar.gz
gentoo-2-c8cad06961b104430db5f6f0247a9a327829fe8c.tar.bz2
gentoo-2-c8cad06961b104430db5f6f0247a9a327829fe8c.zip
another new version out
Diffstat (limited to 'app-vim/zoomwin/zoomwin-16.ebuild')
-rw-r--r--app-vim/zoomwin/zoomwin-16.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-vim/zoomwin/zoomwin-16.ebuild b/app-vim/zoomwin/zoomwin-16.ebuild
new file mode 100644
index 000000000000..5c5dd0221946
--- /dev/null
+++ b/app-vim/zoomwin/zoomwin-16.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/zoomwin/zoomwin-16.ebuild,v 1.1 2003/12/23 16:43:44 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: brief-style window zooming"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=508"
+LICENSE="vim"
+KEYWORDS="~alpha ~sparc ~x86 ~ppc"
+
+function src_unpack() {
+ unpack ${A}
+ mkdir ${S}/doc || die "can't make doc dir"
+
+ # This plugin uses an 'automatic HelpExtractor' variant. This causes
+ # problems for us during the unmerge. Fortunately, sed can fix this
+ # for us.
+ sed -e '1,/^" HelpExtractorDoc:$/d' \
+ ${S}/plugin/ZoomWin.vim > ${S}/doc/ZoomWin.txt \
+ || die "help extraction failed"
+ sed -i -e '/^" HelpExtractor:$/,$d' ${S}/plugin/ZoomWin.vim \
+ || die "help extract remove failed"
+}