summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-12-19 06:04:03 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-12-19 06:04:03 +0000
commit62d841981fe24543e3a18c6a76783c11b8530207 (patch)
treebbb9abef10787ad19810af4822cc65837b01ffc3 /dev-libs/newt
parentKeyworded x86 and ppc for GNOME 2.8.1 (Manifest recommit) (diff)
downloadgentoo-2-62d841981fe24543e3a18c6a76783c11b8530207.tar.gz
gentoo-2-62d841981fe24543e3a18c6a76783c11b8530207.tar.bz2
gentoo-2-62d841981fe24543e3a18c6a76783c11b8530207.zip
Bug #74508, not parallel-safe during make for high values of -j.
Diffstat (limited to 'dev-libs/newt')
-rw-r--r--dev-libs/newt/ChangeLog5
-rw-r--r--dev-libs/newt/newt-0.50.35-r4.ebuild8
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-libs/newt/ChangeLog b/dev-libs/newt/ChangeLog
index 7cb924668df6..41a03fc68073 100644
--- a/dev-libs/newt/ChangeLog
+++ b/dev-libs/newt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/newt
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.14 2004/12/15 07:30:28 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.15 2004/12/19 06:04:03 robbat2 Exp $
+
+ 18 Dec 2004; Robin H. Johnson <robbat2@gentoo.org> newt-0.50.35-r4.ebuild:
+ Bug #74508, not parallel-safe during make for high values of -j.
*newt-0.50.35-r4 (14 Dec 2004)
diff --git a/dev-libs/newt/newt-0.50.35-r4.ebuild b/dev-libs/newt/newt-0.50.35-r4.ebuild
index 2b83a8f7e352..9fad9dcffbe5 100644
--- a/dev-libs/newt/newt-0.50.35-r4.ebuild
+++ b/dev-libs/newt/newt-0.50.35-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.50.35-r4.ebuild,v 1.1 2004/12/15 07:30:28 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.50.35-r4.ebuild,v 1.2 2004/12/19 06:04:03 robbat2 Exp $
inherit python toolchain-funcs
@@ -35,14 +35,16 @@ src_unpack() {
src_compile() {
python_version
econf || die
- emake PYTHONVERS="python${PYVER}" RPM_OPT_FLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "make failure"
+ # not parallel safe
+ emake -j1 PYTHONVERS="python${PYVER}" RPM_OPT_FLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "make failure"
}
src_install () {
python_version
# the RPM_OPT_FLAGS="ERROR" is there to catch a build error
# if it fails, that means something in src_compile() didn't build properly
- emake prefix="${D}/usr" PYTHONVERS="python${PYVER}" RPM_OPT_FLAGS="ERROR" install || die "make install failed"
+ # not parallel safe
+ emake -j1 prefix="${D}/usr" PYTHONVERS="python${PYVER}" RPM_OPT_FLAGS="ERROR" install || die "make install failed"
dodoc CHANGES COPYING peanuts.py popcorn.py tutorial.sgml
dosym libnewt.so.${PV} /usr/lib/libnewt.so.0.50
}