summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-12-16 06:49:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-12-16 06:49:45 +0000
commitfea2506302b0222ed06695334830e7f7ba67e254 (patch)
tree719e8c0049e7c94e55712a801482843e47698274 /dev-php/php/php-4.3.10.ebuild
parentkeywords ~amd64 to close bug 73496. (Manifest recommit) (diff)
downloadgentoo-2-fea2506302b0222ed06695334830e7f7ba67e254.tar.gz
gentoo-2-fea2506302b0222ed06695334830e7f7ba67e254.tar.bz2
gentoo-2-fea2506302b0222ed06695334830e7f7ba67e254.zip
New version, solves bugs #73698, 73525, 72752, 72735.
Diffstat (limited to 'dev-php/php/php-4.3.10.ebuild')
-rw-r--r--dev-php/php/php-4.3.10.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-php/php/php-4.3.10.ebuild b/dev-php/php/php-4.3.10.ebuild
new file mode 100644
index 000000000000..1dfc67002ed3
--- /dev/null
+++ b/dev-php/php/php-4.3.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.10.ebuild,v 1.1 2004/12/16 06:45:44 robbat2 Exp $
+
+PHPSAPI="cli"
+inherit php-sapi eutils
+
+DESCRIPTION="PHP Shell Interpreter"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~s390 ~ppc64 ~mips"
+IUSE=""
+
+src_unpack() {
+ php-sapi_src_unpack
+ [ "${ARCH}" == "amd64" ] && epatch ${FILESDIR}/php-4.3.4-amd64hack.diff
+}
+
+src_compile() {
+ myconf="${myconf} \
+ --disable-cgi \
+ --enable-cli"
+
+ php-sapi_src_compile
+}
+
+
+src_install() {
+ PHP_INSTALLTARGETS="install"
+ php-sapi_src_install
+
+ einfo "Installing manpage"
+ doman sapi/cli/php.1
+}
+
+pkg_postinst() {
+ php-sapi_pkg_postinst
+ einfo "This is a CLI only build."
+ einfo "You cannot use it on a webserver."
+
+ if [ -f "${ROOT}/root/.pearrc" -a "`md5sum ${ROOT}/root/.pearrc`" = "f0243f51b2457bc545158cf066e4e7a2 ${ROOT}/root/.pearrc" ]; then
+ einfo "Cleaning up an old PEAR install glitch"
+ mv ${ROOT}/root/.pearrc ${ROOT}/root/.pearrc.`date +%Y%m%d%H%M%S`
+ fi
+}