summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-10-18 06:27:19 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-10-18 06:27:19 +0000
commit2809910724474f135ecf23d9c87175d2cdf0747a (patch)
tree0c2a192f2d1faf57c03d145f6adef49dacd20c0b /dev-php/php
parentReadded png support. fixes #8882 (diff)
downloadgentoo-2-2809910724474f135ecf23d9c87175d2cdf0747a.tar.gz
gentoo-2-2809910724474f135ecf23d9c87175d2cdf0747a.tar.bz2
gentoo-2-2809910724474f135ecf23d9c87175d2cdf0747a.zip
make sure pdflib and libgd are not merged together. fixes #8883
Diffstat (limited to 'dev-php/php')
-rw-r--r--dev-php/php/php-4.2.2-r1.ebuild5
-rw-r--r--dev-php/php/php-4.2.3.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/dev-php/php/php-4.2.2-r1.ebuild b/dev-php/php/php-4.2.2-r1.ebuild
index 9f523a53d81b..0879063ab8a0 100644
--- a/dev-php/php/php-4.2.2-r1.ebuild
+++ b/dev-php/php/php-4.2.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Update: Roman Weber <gentoo@gonzo.ch>
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.2-r1.ebuild,v 1.15 2002/10/18 06:21:35 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.2-r1.ebuild,v 1.16 2002/10/18 06:25:13 rphillips Exp $
IUSE="freetype postgres tiff libwww nls jpeg readline ssl gd #java mysql X gdbm curl imap png xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb firebird pam oci8"
@@ -102,14 +102,13 @@ src_compile() {
use odbc && myconf="${myconf} --with-unixODBC=/usr"
use ldap && myconf="${myconf} --with-ldap"
use firebird && myconf="${myconf} --with-interbase=/opt/interbase"
- use gd && myconf="${myconf} --with-gd"
use freetype && myconf="${myconf} --with-ttf --with-t1lib"
- use tiff && myconf="${myconf} --with-tiff-dir=/usr"
# rphillips - should fix #2708
if [ "`use pdflib`" ] ; then
myconf="${myconf} --enable-pdflib=/usr"
else
+ use gd && myconf="${myconf} --with-gd"
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
use png && myconf="${myconf} --with-png-dir=/usr"
diff --git a/dev-php/php/php-4.2.3.ebuild b/dev-php/php/php-4.2.3.ebuild
index fcbc4802451a..51b91fde9fc6 100644
--- a/dev-php/php/php-4.2.3.ebuild
+++ b/dev-php/php/php-4.2.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Update: Roman Weber <gentoo@gonzo.ch>
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.3.ebuild,v 1.6 2002/10/18 06:21:35 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.2.3.ebuild,v 1.7 2002/10/18 06:25:13 rphillips Exp $
IUSE="freetype postgres tiff libwww nls jpeg readline ssl gd oci8 mysql X gdbm curl imap png xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
@@ -106,14 +106,13 @@ src_compile() {
use odbc && myconf="${myconf} --with-unixODBC=/usr"
use ldap && myconf="${myconf} --with-ldap"
use firebird && myconf="${myconf} --with-interbase=/opt/interbase"
- use gd && myconf="${myconf} --with-gd"
use freetype && myconf="${myconf} --with-ttf --with-t1lib"
- use tiff && myconf="${myconf} --with-tiff-dir=/usr"
# rphillips - should fix #2708
if [ "`use pdflib`" ] ; then
myconf="${myconf} --enable-pdflib=/usr"
else
+ use gd && myconf="${myconf} --with-gd"
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
use png && myconf="${myconf} --with-png-dir=/usr"