summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-07-29 23:11:42 +0000
committerJoshua Brindle <method@gentoo.org>2003-07-29 23:11:42 +0000
commitd06ff71368b2b535fdfc13aee1ed43ac71e3e6d1 (patch)
treeab2709d3282d69c363a17ff3a3f8b7007a8aa7be /dev-python/python-selinux
parentfixed it so that it will throw an exception on load if no selinux kernel (diff)
downloadgentoo-2-d06ff71368b2b535fdfc13aee1ed43ac71e3e6d1.tar.gz
gentoo-2-d06ff71368b2b535fdfc13aee1ed43ac71e3e6d1.tar.bz2
gentoo-2-d06ff71368b2b535fdfc13aee1ed43ac71e3e6d1.zip
fixed it so that it will throw an exception on load if no selinux kernel
Diffstat (limited to 'dev-python/python-selinux')
-rw-r--r--dev-python/python-selinux/ChangeLog7
-rw-r--r--dev-python/python-selinux/Manifest4
-rw-r--r--dev-python/python-selinux/files/digest-python-selinux-1.11
-rw-r--r--dev-python/python-selinux/python-selinux-1.1.ebuild27
4 files changed, 36 insertions, 3 deletions
diff --git a/dev-python/python-selinux/ChangeLog b/dev-python/python-selinux/ChangeLog
index b9f6dbffda40..8492baf48eeb 100644
--- a/dev-python/python-selinux/ChangeLog
+++ b/dev-python/python-selinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/python-selinux
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.2 2003/07/10 00:24:19 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/ChangeLog,v 1.3 2003/07/29 23:11:39 method Exp $
+
+*python-selinux-1.1 (29 Jul 2003)
+
+ 29 Jul 2003; Joshua Brindle <method@gentoo.org> python-selinux-1.1.ebuild:
+ fixed it so that it will throw an exception on load if no selinux kernel
*python-selinux-1.0-r1 (09 Jul 2003)
diff --git a/dev-python/python-selinux/Manifest b/dev-python/python-selinux/Manifest
index f740b9c01d45..a7318d251f7c 100644
--- a/dev-python/python-selinux/Manifest
+++ b/dev-python/python-selinux/Manifest
@@ -1,6 +1,6 @@
MD5 afbd1cf62fa9f3d52ea9f0de38d5693b python-selinux-1.0-r1.ebuild 723
-MD5 afbd1cf62fa9f3d52ea9f0de38d5693b python-selinux-1.1.ebuild 723
-MD5 63935a81c3d9cf2860c4a4f3678903f0 ChangeLog 791
+MD5 85ef6e845f8c42005bdeb76a61da02b4 python-selinux-1.1.ebuild 720
+MD5 8734367d9986de3916e81b4df5135ff1 ChangeLog 791
MD5 f182ab46e74041b1e72cc2f0e31d09d7 metadata.xml 418
MD5 1732ae6774faefc18325a59dbe3717fd files/digest-python-selinux-1.1 69
MD5 f4f53a607d0d144110d027de26861546 files/digest-python-selinux-1.0-r1 69
diff --git a/dev-python/python-selinux/files/digest-python-selinux-1.1 b/dev-python/python-selinux/files/digest-python-selinux-1.1
new file mode 100644
index 000000000000..0ddd99db3e46
--- /dev/null
+++ b/dev-python/python-selinux/files/digest-python-selinux-1.1
@@ -0,0 +1 @@
+MD5 94cfdd6f663801dcdf36746d7b68ed9e python-selinux-1.1.tar.bz2 5172
diff --git a/dev-python/python-selinux/python-selinux-1.1.ebuild b/dev-python/python-selinux/python-selinux-1.1.ebuild
new file mode 100644
index 000000000000..c353135545c9
--- /dev/null
+++ b/dev-python/python-selinux/python-selinux-1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-selinux/python-selinux-1.1.ebuild,v 1.1 2003/07/29 23:11:39 method Exp $
+
+DESCRIPTION="Python bindings for SELinux functions"
+HOMEPAGE="http://selinux.dev.gentoo.org/python"
+SRC_URI="http://selinux.dev.gentoo.org/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE="selinux"
+
+DEPEND="sys-apps/selinux-small"
+RDEPEND="sys-apps/selinux-small"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ cd ${S}
+ gcc -shared -o selinux.so -I /usr/include/python2.2/ selinux.c -lsecure
+}
+
+src_install() {
+ insinto /usr/lib/python2.2/site-packages
+ doins selinux.so
+}