summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-03-24 08:18:37 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-03-24 08:18:37 +0000
commitb415d950e3f2118ce7a111e51d9b02047f30a81f (patch)
treed6facfec3a6dc115992dd54b0a54e076d5b5d127 /dev-util
parent056 release (diff)
downloadgentoo-2-b415d950e3f2118ce7a111e51d9b02047f30a81f.tar.gz
gentoo-2-b415d950e3f2118ce7a111e51d9b02047f30a81f.tar.bz2
gentoo-2-b415d950e3f2118ce7a111e51d9b02047f30a81f.zip
Version bump as per bug #85998.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/monotone/ChangeLog8
-rw-r--r--dev-util/monotone/Manifest4
-rw-r--r--dev-util/monotone/files/digest-monotone-0.171
-rw-r--r--dev-util/monotone/monotone-0.17.ebuild69
4 files changed, 80 insertions, 2 deletions
diff --git a/dev-util/monotone/ChangeLog b/dev-util/monotone/ChangeLog
index 837ada628835..5e6300ee238c 100644
--- a/dev-util/monotone/ChangeLog
+++ b/dev-util/monotone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/monotone
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.4 2005/01/03 21:24:58 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.5 2005/03/24 08:18:37 dragonheart Exp $
+
+*monotone-0.17 (24 Mar 2005)
+
+ 24 Mar 2005; Daniel Black <dragonheart@gentoo.org> +monotone-0.17.ebuild:
+ Version bump as per bug #85998. Ebuild thanks to Wojciech Milkowski
+ <wmilkowski@gazeta.pl>
04 Jan 2005; Daniel Black <dragonheart@gentoo.org> monotone-0.16.ebuild:
enabled self test with a warning about test #62 cause it failed for Wojciech
diff --git a/dev-util/monotone/Manifest b/dev-util/monotone/Manifest
index 3f606c5d7022..58cbc51de9b6 100644
--- a/dev-util/monotone/Manifest
+++ b/dev-util/monotone/Manifest
@@ -1,4 +1,6 @@
-MD5 5ad1916582e8bf7b7d89f933e9605821 ChangeLog 1150
+MD5 c04c534ad2ac319361fe22df42579f64 monotone-0.17.ebuild 1740
MD5 6d796b061ed1c1337ef157a5f74dab35 metadata.xml 403
+MD5 5ad1916582e8bf7b7d89f933e9605821 ChangeLog 1150
MD5 dde934a3d504967d4678c4302ddd971e monotone-0.16.ebuild 1233
MD5 f7dab86750bae0e4ff09e2139b790084 files/digest-monotone-0.16 66
+MD5 c8834d71dc37833961a7eb7b4a455e84 files/digest-monotone-0.17 66
diff --git a/dev-util/monotone/files/digest-monotone-0.17 b/dev-util/monotone/files/digest-monotone-0.17
new file mode 100644
index 000000000000..72ecc7f58f47
--- /dev/null
+++ b/dev-util/monotone/files/digest-monotone-0.17
@@ -0,0 +1 @@
+MD5 a412ce38f5e91a210363bf8811639d96 monotone-0.17.tar.gz 4001679
diff --git a/dev-util/monotone/monotone-0.17.ebuild b/dev-util/monotone/monotone-0.17.ebuild
new file mode 100644
index 000000000000..b4ed71562cdd
--- /dev/null
+++ b/dev-util/monotone/monotone-0.17.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.17.ebuild,v 1.1 2005/03/24 08:18:37 dragonheart Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Monotone Distributed Version Control System"
+HOMEPAGE="http://www.venge.net/monotone/"
+SRC_URI="http://www.venge.net/monotone/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="x86 ~amd64"
+#KEYWORDS ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64"
+
+IUSE="nls doc"
+
+RDEPEND=">=dev-libs/boost-1.31.0
+ dev-libs/popt"
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-3.3.3
+ sys-devel/gettext"
+# doc? ( dev-lang/perl sys-apps/texinfo )"
+
+src_compile() {
+
+ # more aggressive optimizations cause trouble with the
+ # crypto library
+ # disable stack protector
+
+ strip-flags
+ # replace-flags -O3 -O2
+ append-flags -fno-stack-protector-all -fno-stack-protector -fno-strict-aliasing
+
+ econf `use_enable nls` || die
+ emake || die "emake failed"
+}
+
+src_test() {
+ make check
+ einfo "test may fail on test 62"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use doc ; then
+ dodoc figures/*.pdf
+ # Generate html docs - broken - missing images from figures directory
+ # emake html || die "emake html failed"
+ # dohtml -r html/*
+ fi
+
+
+ dodoc NEWS
+ dodoc UPGRADE
+
+ # Slotting
+ OLD_N=${PN}
+ NEW_N=${PN}-${PV}
+ cd ${D}/usr
+ mv bin/${OLD_N} bin/${NEW_N}
+ mv share/info/${OLD_N}.info share/info/${NEW_N}.info
+ mv share/man/man1/${OLD_N}.1 share/man/man1/${NEW_N}.1
+
+ ewarn "For incopatibility reasons new monotone binary was renamed to \"${NEW_N}\""
+ ewarn "If you want to use new features of ${PN} you have to upgrade your existing"
+ ewarn "databases as described in /usr/share/doc/${P}/UPGRAGE.gz document."
+}