summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-10-24 18:38:39 +0000
committerDan Armak <danarmak@gentoo.org>2002-10-24 18:38:39 +0000
commitea084e4e0d2d35bcd9ee85beba50bcda0647aa0b (patch)
tree0ce742ab8630636b79e1f9d5b91833b43d3f3b6c /eclass
parentadded dependency on kde-base, fixes #9402 (diff)
downloadgentoo-2-ea084e4e0d2d35bcd9ee85beba50bcda0647aa0b.tar.gz
gentoo-2-ea084e4e0d2d35bcd9ee85beba50bcda0647aa0b.tar.bz2
gentoo-2-ea084e4e0d2d35bcd9ee85beba50bcda0647aa0b.zip
fix identation (proper tabs everywhere, alignment) in my eclasses
Diffstat (limited to 'eclass')
-rw-r--r--eclass/base.eclass38
-rw-r--r--eclass/cvs.eclass62
-rw-r--r--eclass/kde-dist.eclass6
-rw-r--r--eclass/kde-functions.eclass202
-rw-r--r--eclass/kde-i18n.eclass24
-rw-r--r--eclass/kde-i18n.org.eclass16
-rw-r--r--eclass/kde-patch.eclass10
-rw-r--r--eclass/kde-source.eclass10
-rw-r--r--eclass/kde.eclass29
-rw-r--r--eclass/kde.org.eclass18
10 files changed, 206 insertions, 209 deletions
diff --git a/eclass/base.eclass b/eclass/base.eclass
index 4ee2e4eb14f1..cef8044c39fc 100644
--- a/eclass/base.eclass
+++ b/eclass/base.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/base.eclass,v 1.16 2002/07/12 15:24:36 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/base.eclass,v 1.17 2002/10/24 18:38:32 danarmak Exp $
# The base eclass defines some default functions and variables. Nearly everything
# else inherits from here.
ECLASS=base
@@ -19,32 +19,32 @@ base_src_unpack() {
while [ "$1" ]; do
case $1 in
- unpack)
+ unpack)
debug-print-section unpack
# rather ugly fix - check for usage of kde-patch.eclass
[ -n "$PATCH" -a -n "$ORIGPV" -a -n "$DATE" -a -n "$OLDIFS" ] && \
- A="`echo $A | sed -e s:${PATCH}::g --`"
+ A="`echo $A | sed -e s:${PATCH}::g --`"
unpack ${A}
;;
- patch)
+ patch)
debug-print-section patch
cd ${S}
patch -p0 < ${FILESDIR}/${P}-gentoo.diff
;;
- autopatch)
+ autopatch)
debug-print-section autopatch
debug-print "$FUNCNAME: autopatch: PATCHES=$PATCHES"
cd ${S}
for x in $PATCHES; do
- debug-print "$FUNCNAME: autopatch: patching from ${x}"
- patch -p0 < ${x}
+ debug-print "$FUNCNAME: autopatch: patching from ${x}"
+ patch -p0 < ${x}
done
;;
all)
debug-print-section all
base_src_unpack unpack autopatch
;;
- esac
+ esac
shift
done
@@ -53,30 +53,30 @@ base_src_unpack() {
base_src_compile() {
- debug-print-function $FUNCNAME $*
- [ -z "$1" ] && base_src_compile all
+ debug-print-function $FUNCNAME $*
+ [ -z "$1" ] && base_src_compile all
- cd ${S}
+ cd ${S}
- while [ "$1" ]; do
+ while [ "$1" ]; do
case $1 in
- configure)
+ configure)
debug-print-section configure
econf || die "died running econf, $FUNCNAME:configure"
;;
- make)
+ make)
debug-print-section make
emake || die "died running emake, $FUNCNAME:make"
;;
- all)
+ all)
debug-print-section all
base_src_compile configure make
;;
esac
- shift
- done
+ shift
+ done
}
@@ -90,11 +90,11 @@ base_src_install() {
while [ "$1" ]; do
case $1 in
- make)
+ make)
debug-print-section make
make DESTDIR=${D} install || die "died running make install, $FUNCNAME:make"
;;
- all)
+ all)
debug-print-section all
base_src_install make
;;
diff --git a/eclass/cvs.eclass b/eclass/cvs.eclass
index 1e96a5d39c18..78facd11c350 100644
--- a/eclass/cvs.eclass
+++ b/eclass/cvs.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/cvs.eclass,v 1.20 2002/09/22 18:43:20 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/cvs.eclass,v 1.21 2002/10/24 18:38:32 danarmak Exp $
# This eclass provides the generic cvs fetching functions.
ECLASS=cvs
@@ -84,14 +84,14 @@ DIR=$DIR"
if [ "$ECVS_SERVER" == "offline" ]; then
# we're not required to fetch anything, the module already exists and shouldn't be updated
- if [ -d "$DIR" ]; then
+ if [ -d "$DIR" ]; then
debug-print "$FUNCNAME: offline mode, exiting"
return 0
- else
+ else
einfo "ERROR: Offline mode specified, but module/subdir not found. Aborting."
debug-print "$FUNCNAME: offline mode specified but module/subdir not found, exiting with error"
return 1
- fi
+ fi
fi
# create target directory as needed
@@ -125,7 +125,7 @@ DIR=$DIR"
echo ":pserver:${ECVS_SERVER} A" > ${T}/cvspass
export CVS_PASSFILE="${T}/cvspass"
#export CVSROOT=:pserver:${ECVS_USER}@${ECVS_SERVER}
-
+
# Note: cvs update and checkout commands are unified.
# we make sure a CVS/ dir exists in our module subdir with the right
# Root and Repository entries in it and cvs update.
@@ -203,27 +203,27 @@ DIR=$DIR"
cvs_src_unpack() {
- debug-print-function $FUNCNAME $*
+ debug-print-function $FUNCNAME $*
cvs_fetch || die "died running cvs_fetch"
- einfo "Copying $ECVS_MODULE/$ECVS_SUBDIR from $ECVS_TOP_DIR..."
+ einfo "Copying $ECVS_MODULE/$ECVS_SUBDIR from $ECVS_TOP_DIR..."
debug-print "Copying module $ECVS_MODULE subdir $ECVS_SUBDIR local_mode=$ECVS_LOCAL from $ECVS_TOP_DIR..."
# probably redundant, but best to make sure
mkdir -p $WORKDIR/$ECVS_MODULE/$ECVS_SUBDIR
if [ -n "$ECVS_SUBDIR" ]; then
- if [ -n "$ECVS_LOCAL" ]; then
- cp -f $ECVS_TOP_DIR/$ECVS_MODULE/$ECVS_SUBDIR/* $WORKDIR/$ECVS_MODULE/$ECVS_SUBDIR
- else
- cp -Rf $ECVS_TOP_DIR/$ECVS_MODULE/$ECVS_SUBDIR $WORKDIR/$ECVS_MODULE/$ECVS_SUBDIR/..
- fi
+ if [ -n "$ECVS_LOCAL" ]; then
+ cp -f $ECVS_TOP_DIR/$ECVS_MODULE/$ECVS_SUBDIR/* $WORKDIR/$ECVS_MODULE/$ECVS_SUBDIR
+ else
+ cp -Rf $ECVS_TOP_DIR/$ECVS_MODULE/$ECVS_SUBDIR $WORKDIR/$ECVS_MODULE/$ECVS_SUBDIR/..
+ fi
else
- if [ -n "$ECVS_LOCAL" ]; then
- cp -f $ECVS_TOP_DIR/$ECVS_MODULE/* $WORKDIR/$ECVS_MODULE
- else
- cp -Rf $ECVS_TOP_DIR/$ECVS_MODULE $WORKDIR
- fi
+ if [ -n "$ECVS_LOCAL" ]; then
+ cp -f $ECVS_TOP_DIR/$ECVS_MODULE/* $WORKDIR/$ECVS_MODULE
+ else
+ cp -Rf $ECVS_TOP_DIR/$ECVS_MODULE $WORKDIR
+ fi
fi
# if the directory is empty, remove it; empty directories cannot exist in cvs.
@@ -234,22 +234,20 @@ cvs_src_unpack() {
rm -rf $DIR
fi
- # implement some of base_src_unpack's functionality;
- # note however that base.eclass may not have been inherited!
- if [ -n "$PATCHES" ]; then
- debug-print "$FUNCNAME: PATCHES=$PATCHES, S=$S, autopatching"
- cd $S
- for x in $PATCHES; do
- debug-print "patching from $x"
- patch -p0 < $x
- done
- # make sure we don't try to apply patches more than once, since
- # cvs_src_unpack is usually called several times from e.g. kde-source_src_unpack
- export PATCHES=""
- fi
+ # implement some of base_src_unpack's functionality;
+ # note however that base.eclass may not have been inherited!
+ if [ -n "$PATCHES" ]; then
+ debug-print "$FUNCNAME: PATCHES=$PATCHES, S=$S, autopatching"
+ cd $S
+ for x in $PATCHES; do
+ debug-print "patching from $x"
+ patch -p0 < $x
+ done
+ # make sure we don't try to apply patches more than once, since
+ # cvs_src_unpack is usually called several times from e.g. kde-source_src_unpack
+ export PATCHES=""
+ fi
}
EXPORT_FUNCTIONS src_unpack
-
-
diff --git a/eclass/kde-dist.eclass b/eclass/kde-dist.eclass
index 0ea2506ff412..12807de0806f 100644
--- a/eclass/kde-dist.eclass
+++ b/eclass/kde-dist.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-dist.eclass,v 1.21 2002/09/24 17:54:19 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-dist.eclass,v 1.22 2002/10/24 18:38:34 danarmak Exp $
# This is the kde-dist eclass for >=2.2.1 kde base packages. Don't use for kdelibs though :-)
# Don't use it for e.g. kdevelop, koffice because of their separate versionnig schemes.
inherit kde-base kde.org
@@ -20,8 +20,8 @@ HOMEPAGE="http://www.kde.org/"
# doesn't work well for unstable versions
if [ "$PV" != "3.1_alpha1" -a "$PV" != "3.1_beta1" -a "$PV" != "3.1_beta2" -a "$PV" != "5" ]; then
- myconf="$myconf --enable-final"
- debug-print "$ECLASS: added enable-final"
+ myconf="$myconf --enable-final"
+ debug-print "$ECLASS: added enable-final"
fi
LICENSE="GPL-2"
diff --git a/eclass/kde-functions.eclass b/eclass/kde-functions.eclass
index 13ba500037f4..1d992e109180 100644
--- a/eclass/kde-functions.eclass
+++ b/eclass/kde-functions.eclass
@@ -1,40 +1,40 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-functions.eclass,v 1.32 2002/09/24 17:54:19 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-functions.eclass,v 1.33 2002/10/24 18:38:34 danarmak Exp $
# This contains everything except things that modify ebuild variables and functions (e.g. $P, src_compile() etc.)
ECLASS=kde-functions
INHERITED="$INHERITED $ECLASS"
# convinience functions for requesting autotools versions
need-automake() {
- debug-print-function $FUNCNAME $*
+ debug-print-function $FUNCNAME $*
- unset WANT_AUTOMAKE_1_4
- unset WANT_AUTOMAKE_1_5
- unset WANT_AUTOMAKE_1_6
+ unset WANT_AUTOMAKE_1_4
+ unset WANT_AUTOMAKE_1_5
+ unset WANT_AUTOMAKE_1_6
- case $1 in
- 1.4) export WANT_AUTOMAKE_1_4=1;;
- 1.5) export WANT_AUTOMAKE_1_5=1;;
- 1.6) export WANT_AUTOMAKE_1_6=1;;
- *) echo "!!! $FUNCNAME: Error: unrecognized automake version $1 requested";;
- esac
+ case $1 in
+ 1.4) export WANT_AUTOMAKE_1_4=1;;
+ 1.5) export WANT_AUTOMAKE_1_5=1;;
+ 1.6) export WANT_AUTOMAKE_1_6=1;;
+ *) echo "!!! $FUNCNAME: Error: unrecognized automake version $1 requested";;
+ esac
}
need-autoconf() {
- debug-print-function $FUNCNAME $*
+ debug-print-function $FUNCNAME $*
- unset WANT_AUTOCONF_2_1
- unset WANT_AUTOCONF_2_5
+ unset WANT_AUTOCONF_2_1
+ unset WANT_AUTOCONF_2_5
- case $1 in
- 2.1) export WANT_AUTOCONF_2_1=1;;
- 2.5) export WANT_AUTOCONF_2_5=1;;
- *) echo "!!! $FUNCNAME: Error: unrecognized autoconf version $1 requested";;
- esac
+ case $1 in
+ 2.1) export WANT_AUTOCONF_2_1=1;;
+ 2.5) export WANT_AUTOCONF_2_5=1;;
+ *) echo "!!! $FUNCNAME: Error: unrecognized autoconf version $1 requested";;
+ esac
}
@@ -54,15 +54,15 @@ need-kde() {
# if we're a kde-base package, we need an exact version of kdelibs
# to compile correctly.
if [ "${INHERITED//kde-dist}" != "$INHERITED" ]; then
- # kde 3.0.3 and 2.2.2 are special cases, because 3.0.3a and 2.2.2a exist.
- # goes to show this code is awfully inflexible, i guess.
- if [ "$PV" == "3.0.3" ]; then
- newdepend "=kde-base/kdelibs-3.0.3*"
- elif [ "$PV" == "2.2.2" ]; then
- newdepend "=kde-base/kdelibs-2.2.2*"
- else
- newdepend "~kde-base/kdelibs-${KDEVER}"
- fi
+ # kde 3.0.3 and 2.2.2 are special cases, because 3.0.3a and 2.2.2a exist.
+ # goes to show this code is awfully inflexible, i guess.
+ if [ "$PV" == "3.0.3" ]; then
+ newdepend "=kde-base/kdelibs-3.0.3*"
+ elif [ "$PV" == "2.2.2" ]; then
+ newdepend "=kde-base/kdelibs-2.2.2*"
+ else
+ newdepend "~kde-base/kdelibs-${KDEVER}"
+ fi
elif [ -n "$KDEAPPENDAGE" ]; then
# special status - installs into $KDEDIR not $PREFIX
# and needs an exact minor version of kde.
@@ -79,16 +79,16 @@ need-kde() {
else
min-kde-ver $KDEVER
newdepend ">=kde-base/kdelibs-${selected_version}"
- fi
+ fi
fi
qtver-from-kdever $KDEVER
need-qt $selected_version
if [ -n "$KDEBASE" ]; then
- SLOT="$KDEMAJORVER.$KDEMINORVER"
+ SLOT="$KDEMAJORVER.$KDEMINORVER"
else
- SLOT="0"
+ SLOT="0"
fi
}
@@ -103,27 +103,27 @@ set-kdedir() {
fi
case "$1" in
- 2*)
- need-autoconf 2.1
- need-automake 1.4
- ;;
- 3.0*)
- if [ -n "$KDEBASE" ]; then
- # used by 3.0.x kdebase stuff, not by 3rd party apps
- need-autoconf 2.1
- else
- need-autoconf 2.5
- fi
- need-automake 1.4
- ;;
- 3*)
- need-autoconf 2.5
- need-automake 1.4
- ;;
- 5*)
- need-autoconf 2.5
- need-automake 1.4
- ;;
+ 2*)
+ need-autoconf 2.1
+ need-automake 1.4
+ ;;
+ 3.0*)
+ if [ -n "$KDEBASE" ]; then
+ # used by 3.0.x kdebase stuff, not by 3rd party apps
+ need-autoconf 2.1
+ else
+ need-autoconf 2.5
+ fi
+ need-automake 1.4
+ ;;
+ 3*)
+ need-autoconf 2.5
+ need-automake 1.4
+ ;;
+ 5*)
+ need-autoconf 2.5
+ need-automake 1.4
+ ;;
esac
# set install location:
@@ -158,7 +158,7 @@ set-kdedir() {
[ -z "$KDEREVISION" ] && KDEREVISION="0"
IFS="$IFSBACKUP"
debug-print "$FUNCNAME: version breakup: KDEMAJORVER=$KDEMAJORVER KDEMINORVER=$KDEMINORVER KDEREVISION=$KDEREVISION"
-
+
# install prefix
@@ -262,8 +262,8 @@ qtver-from-kdever() {
case $1 in
2*) ver=2.3.1;;
3*) ver=3.0.4;;
- 5) ver=3.0.4;; # cvs version
- *) echo "!!! error: $FUNCNAME called with invalid parameter: \"$1\", please report bug" && exit 1;;
+ 5) ver=3.0.4;; # cvs version
+ *) echo "!!! error: $FUNCNAME called with invalid parameter: \"$1\", please report bug" && exit 1;;
esac
selected_version="$ver"
@@ -272,9 +272,9 @@ qtver-from-kdever() {
# compat
need-kdelibs() {
- echo "WARNING: need-kdelibs() called, where need-kde() is correct.
+ echo "WARNING: need-kdelibs() called, where need-kde() is correct.
If this happens at the unmerging of an old ebuild, disregard; otherwise report."
- need-kde $*
+ need-kde $*
}
min-kde-ver() {
@@ -282,21 +282,21 @@ min-kde-ver() {
debug-print-function $FUNCNAME $*
case $1 in
- 2*) selected_version="2.2.2";;
- 3.0_beta1) selected_version="3.0_beta1";;
- 3.0_beta2) selected_version="3.0_beta2";;
- 3.0_rc1) selected_version="3.0_rc1";;
- 3.0_rc2) selected_version="3.0_rc2";;
- 3.0_rc3) selected_version="3.0_rc3";;
- 3.0) selected_version="3.0";;
- 3.0.*) selected_version="3.0";;
- 3.1_alpha1) selected_version="3.1_alpha1";;
- 3.1_beta1) selected_version="3.1_alpha1";;
- 3.1_beta2) selected_version="3.1_alpha1";;
- 3.1.*) selected_version="3.1";;
- 3*) selected_version="3.0";;
- 5) selected_version="5";;
- *) echo "!!! error: $FUNCNAME() called with invalid parameter: \"$1\", please report bug" && exit 1;;
+ 2*) selected_version="2.2.2";;
+ 3.0_beta1) selected_version="3.0_beta1";;
+ 3.0_beta2) selected_version="3.0_beta2";;
+ 3.0_rc1) selected_version="3.0_rc1";;
+ 3.0_rc2) selected_version="3.0_rc2";;
+ 3.0_rc3) selected_version="3.0_rc3";;
+ 3.0) selected_version="3.0";;
+ 3.0.*) selected_version="3.0";;
+ 3.1_alpha1) selected_version="3.1_alpha1";;
+ 3.1_beta1) selected_version="3.1_alpha1";;
+ 3.1_beta2) selected_version="3.1_alpha1";;
+ 3.1.*) selected_version="3.1";;
+ 3*) selected_version="3.0";;
+ 5) selected_version="5";;
+ *) echo "!!! error: $FUNCNAME() called with invalid parameter: \"$1\", please report bug" && exit 1;;
esac
}
@@ -309,22 +309,22 @@ min-kde-ver() {
# This should be harmless if the makefile doesn't need fixing.
kde_sandbox_patch() {
- debug-print-function $FUNCNAME $*
+ debug-print-function $FUNCNAME $*
- while [ -n "$1" ]; do
+ while [ -n "$1" ]; do
# can't use dosed, because it only works for things in ${D}, not ${S}
cd $1
for x in Makefile.am Makefile.in Makefile
do
- if [ -f "$x" ]; then
- echo Running sed on $x
- cp $x ${x}.orig
- sed -e 's: $(bindir): $(DESTDIR)/$(bindir):g' -e 's: $(kde_datadir): $(DESTDIR)/$(kde_datadir):g' -e 's: $(TIMID_DIR): $(DESTDIR)/$(TIMID_DIR):g' ${x}.orig > ${x}
- rm ${x}.orig
- fi
+ if [ -f "$x" ]; then
+ echo Running sed on $x
+ cp $x ${x}.orig
+ sed -e 's: $(bindir): $(DESTDIR)/$(bindir):g' -e 's: $(kde_datadir): $(DESTDIR)/$(kde_datadir):g' -e 's: $(TIMID_DIR): $(DESTDIR)/$(TIMID_DIR):g' ${x}.orig > ${x}
+ rm ${x}.orig
+ fi
done
shift
- done
+ done
}
@@ -337,16 +337,16 @@ kde_sandbox_patch() {
# $2: flag to remove
kde_remove_flag() {
- debug-print-function $FUNCNAME $*
+ debug-print-function $FUNCNAME $*
- cd ${S}/${1} || die
- [ -n "$2" ] || die
+ cd ${S}/${1} || die
+ [ -n "$2" ] || die
- cp Makefile Makefile.orig
- sed -e "/CFLAGS/ s/${2}//g
+ cp Makefile Makefile.orig
+ sed -e "/CFLAGS/ s/${2}//g
/CXXFLAGS/ s/${2}//g" Makefile.orig > Makefile
- cd $OLDPWD
+ cd $OLDPWD
}
@@ -356,29 +356,29 @@ kde_remove_flag() {
# $KDE_REMOVE_DIR is then passed as parameter
kde_remove_dir(){
- debug-print-function $FUNCNAME $*
+ debug-print-function $FUNCNAME $*
- cd ${S}
+ cd ${S}
- while [ -n "$1" ]; do
- for dir in $1; do
+ while [ -n "$1" ]; do
+ for dir in $1; do
- debug-print "$FUNCNAME: removing subdirectory $dir"
+ debug-print "$FUNCNAME: removing subdirectory $dir"
- rm -rf $dir
+ rm -rf $dir
- if [ -f subdirs ]; then
- mv subdirs subdirs.orig
- grep -v $dir subdirs.orig > subdirs
- fi
+ if [ -f subdirs ]; then
+ mv subdirs subdirs.orig
+ grep -v $dir subdirs.orig > subdirs
+ fi
- rm -f configure configure.in
+ rm -f configure configure.in
- export DO_NOT_COMPILE="$DO_NOT_COMPILE $dir"
+ export DO_NOT_COMPILE="$DO_NOT_COMPILE $dir"
- done
+ done
shift
- done
+ done
}
diff --git a/eclass/kde-i18n.eclass b/eclass/kde-i18n.eclass
index b7f32b87242d..8c76fb5ccee8 100644
--- a/eclass/kde-i18n.eclass
+++ b/eclass/kde-i18n.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-i18n.eclass,v 1.24 2002/10/17 23:29:25 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-i18n.eclass,v 1.25 2002/10/24 18:38:34 danarmak Exp $
inherit kde
ECLASS=kde-i18n
INHERITED="$INHERITED $ECLASS"
@@ -19,26 +19,26 @@ myconf="$myconf --enable-final"
need-kde ${PV}
case "$PV" in
- 2.2.2) SRC_PATH="stable/${PV}/src/${P}.tar.bz2" ;;
- 3.1_beta1) SRC_PATH="unstable/kde-3.1-beta1/src/kde-i18n/${P//3.1_beta1/3.0.7}.tar.bz2" ;;
- 3.1_beta2) SRC_PATH="unstable/kde-3.1-beta2/src/kde-i18n/${P//3.1_beta2/3.0.8}.tar.bz2" ;;
- 3*) SRC_PATH="stable/${PV}/src/kde-i18n/${P}.tar.bz2" ;;
+ 2.2.2) SRC_PATH="stable/${PV}/src/${P}.tar.bz2" ;;
+ 3.1_beta1) SRC_PATH="unstable/kde-3.1-beta1/src/kde-i18n/${P//3.1_beta1/3.0.7}.tar.bz2" ;;
+ 3.1_beta2) SRC_PATH="unstable/kde-3.1-beta2/src/kde-i18n/${P//3.1_beta2/3.0.8}.tar.bz2" ;;
+ 3*) SRC_PATH="stable/${PV}/src/kde-i18n/${P}.tar.bz2" ;;
esac
if [ "$PN" == "kde-i18n" ]; then
- SRC_PATH=${SRC_PATH/kde-i18n//}
+ SRC_PATH=${SRC_PATH/kde-i18n//}
fi
SRC_URI="$SRC_URI mirror://kde/$SRC_PATH
http://www.ibiblio.org/gentoo/distfiles/kde-i18n-gentoo.patch"
kde-i18n_src_unpack() {
- unpack ${A//kde-i18n-gentoo.patch} || die
- cd ${S}
- if [ -f "docs/common/Makefile.in" ]; then
- patch -p0 < ${DISTDIR}/kde-i18n-gentoo.patch
- echo Please ignore possible errors about rejected patch above
- fi
+ unpack ${A//kde-i18n-gentoo.patch} || die
+ cd ${S}
+ if [ -f "docs/common/Makefile.in" ]; then
+ patch -p0 < ${DISTDIR}/kde-i18n-gentoo.patch
+ echo Please ignore possible errors about rejected patch above
+ fi
}
EXPORT_FUNCTIONS src_unpack
diff --git a/eclass/kde-i18n.org.eclass b/eclass/kde-i18n.org.eclass
index 7fcb7eec8e96..8862a7729644 100644
--- a/eclass/kde-i18n.org.eclass
+++ b/eclass/kde-i18n.org.eclass
@@ -1,19 +1,19 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-i18n.org.eclass,v 1.5 2002/08/23 16:36:47 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-i18n.org.eclass,v 1.6 2002/10/24 18:38:39 danarmak Exp $
# Contains the locations of i18n ftp.kde.org packages and their mirrors
ECLASS=kde-i18n.org
INHERITED="$INHERITED $ECLASS"
case $PV in
- '3.0.2'|'3.0.3')
- # new location format starting with 3.0.2
- SRC_PATH="kde/stable/${PV}/src/kde-i18n/${P}.tar.bz2"
- ;;
- *)
- SRC_PATH="kde/stable/${PV}/src/${P}.tar.bz2"
- ;;
+ '3.0.2'|'3.0.3')
+ # new location format starting with 3.0.2
+ SRC_PATH="kde/stable/${PV}/src/kde-i18n/${P}.tar.bz2"
+ ;;
+ *)
+ SRC_PATH="kde/stable/${PV}/src/${P}.tar.bz2"
+ ;;
esac
SRC_URI="$SRC_URI ftp://ftp.kde.org/pub/$SRC_PATH
diff --git a/eclass/kde-patch.eclass b/eclass/kde-patch.eclass
index 0b2124dee19e..5b92d9ca3a3c 100644
--- a/eclass/kde-patch.eclass
+++ b/eclass/kde-patch.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-patch.eclass,v 1.2 2002/07/12 15:24:36 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-patch.eclass,v 1.3 2002/10/24 18:38:39 danarmak Exp $
# This applies homemade patches from the tarball to the date specified.
ECLASS=kde-patch
INHERITED="$INHERITED $ECLASS"
@@ -15,14 +15,14 @@ debug-print "Entering eclass $ECLASS"
# I'm not that good at regexps etc., so I emulate std coding practices
OLDIFS="$IFS" # backup so that we don't distort future loops
-IFS="." # separator string that determines the breakup of a string by bash's "for x in; do; done"
+IFS="." # separator string that determines the breakup of a string by bash's "for x in; do; done"
for DATE in $PV
do
- # if not last component of separated $PV
- if [ ! "${ORIGPV}.${DATE}" == "${PV}" ]; then
+ # if not last component of separated $PV
+ if [ ! "${ORIGPV}.${DATE}" == "${PV}" ]; then
[ -n "$ORIGPV" ] && ORIGPV="${ORIGPV}.${DATE}" || ORIGPV="$DATE" # don't add a leading dot
- fi
+ fi
done
IFS="$OLDIFS" #restore
diff --git a/eclass/kde-source.eclass b/eclass/kde-source.eclass
index c02d33b0c622..ed4faa529f9e 100644
--- a/eclass/kde-source.eclass
+++ b/eclass/kde-source.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde-source.eclass,v 1.10 2002/10/20 11:14:50 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde-source.eclass,v 1.11 2002/10/24 18:38:39 danarmak Exp $
# This is for kde-base cvs ebuilds. Read comments about settings.
# It uses $S and sets $SRC_URI, so inherit it as late as possible (certainly after any other eclasses).
@@ -57,7 +57,7 @@ SRC_URI=""
kde-source_src_unpack() {
- debug-print-function $FUNCNAME $*
+ debug-print-function $FUNCNAME $*
cvs_src_unpack
@@ -78,8 +78,8 @@ kde-source_src_unpack() {
# in offline mode cvs.eclass will abort, so only call this if we're
# in online mode or the dir is already fetched
if [ -d "$ECVS_TOP_DIR/$ECVS_MODULE/doc/$ECVS_SUBDIR" -o "$ECVS_SERVER" != "offline" ]; then
- debug-print "$FUNCNAME: fetching doc/$ECVS_SUBDIR..."
- ECVS_SUBDIR=doc/$ECVS_SUBDIR cvs_src_unpack
+ debug-print "$FUNCNAME: fetching doc/$ECVS_SUBDIR..."
+ ECVS_SUBDIR=doc/$ECVS_SUBDIR cvs_src_unpack
fi
fi
@@ -88,7 +88,7 @@ kde-source_src_unpack() {
# which is also needed
if [ ! -d "$S/admin" ]; then
ECVS_MODULE="kde-common" ECVS_SUBDIR="admin" cvs_src_unpack
- mv ${WORKDIR}/kde-common/admin $WORKDIR/$ECVS_MODULE
+ mv ${WORKDIR}/kde-common/admin $WORKDIR/$ECVS_MODULE
fi
# make sure we give them a clean cvs checkout
diff --git a/eclass/kde.eclass b/eclass/kde.eclass
index df7545245671..ace9db76af2a 100644
--- a/eclass/kde.eclass
+++ b/eclass/kde.eclass
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.59 2002/09/24 17:54:20 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.eclass,v 1.60 2002/10/24 18:38:39 danarmak Exp $
# The kde eclass is inherited by all kde-* eclasses. Few ebuilds inherit straight from here.
inherit base kde-functions
ECLASS=kde
@@ -22,7 +22,6 @@ case $PN in
# 3.1_beta1) export S="$WORKDIR/$PN-3.0.7" ;;
# 3.1_beta2) export S="$WORKDIR/$PN-3.0.8" ;;
#esac
-
;;
esac
@@ -37,13 +36,13 @@ SLOT="0"
kde_src_compile() {
- debug-print-function $FUNCNAME $*
- [ -z "$1" ] && kde_src_compile all
+ debug-print-function $FUNCNAME $*
+ [ -z "$1" ] && kde_src_compile all
- cd ${S}
- export kde_widgetdir="$KDEDIR/lib/kde3/plugins/designer"
+ cd ${S}
+ export kde_widgetdir="$KDEDIR/lib/kde3/plugins/designer"
- while [ "$1" ]; do
+ while [ "$1" ]; do
case $1 in
myconf)
@@ -64,12 +63,12 @@ kde_src_compile() {
# rebuild configure script, etc
# This can happen with e.g. a cvs snapshot
if [ ! -f "./configure" ]; then
- for x in Makefile.cvs admin/Makefile.common; do
+ for x in Makefile.cvs admin/Makefile.common; do
if [ -f "$x" ] && [ -z "$makefile" ]; then makefile="$x"; fi
- done
- debug-print "$FUNCNAME: configure: generating configure script, running make -f $makefile"
- make -f $makefile
- [ -f "./configure" ] || die "no configure script found, generation unsuccessful"
+ done
+ debug-print "$FUNCNAME: configure: generating configure script, running make -f $makefile"
+ make -f $makefile
+ [ -f "./configure" ] || die "no configure script found, generation unsuccessful"
fi
export PATH="${KDEDIR}/bin:${PATH}"
@@ -88,8 +87,8 @@ kde_src_compile() {
;;
esac
- shift
- done
+ shift
+ done
}
@@ -110,7 +109,7 @@ kde_src_install() {
dodoc)
debug-print-section dodoc
for doc in AUTHORS ChangeLog* README* COPYING NEWS TODO; do
- [ -f "$doc" ] && dodoc $doc
+ [ -f "$doc" ] && dodoc $doc
done
;;
all)
diff --git a/eclass/kde.org.eclass b/eclass/kde.org.eclass
index f95bf49dbf9a..e0cbcddde38a 100644
--- a/eclass/kde.org.eclass
+++ b/eclass/kde.org.eclass
@@ -1,23 +1,23 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde.org.eclass,v 1.16 2002/09/24 17:54:20 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde.org.eclass,v 1.17 2002/10/24 18:38:39 danarmak Exp $
# Contains the locations of ftp.kde.org packages and their mirrors
ECLASS=kde.org
INHERITED="$INHERITED $ECLASS"
# kde 3.1 prereleases have tarball versions of 3.0.6 ff
case "$PV" in
- 1*) SRC_PATH="stable/3.0.2/src/${P}.tar.bz2";; # backward compatibility for unmerging ebuilds
- 2.2.2) SRC_PATH="Attic/2.2.2/src/${P}.tar.bz2" ;;
- 3.1_alpha1) SRC_PATH="unstable/kde-3.1-alpha1/src/${P//3.1_alpha1/3.0.6}.tar.bz2" ;;
- 3.1_beta1) SRC_PATH="unstable/kde-3.1-beta1/src/${P//3.1_beta1/3.0.7}.tar.bz2" ;;
- 3.1_beta2) SRC_PATH="unstable/kde-3.1-beta2/src/${P//3.1_beta2/3.0.8}.tar.bz2" ;;
- 3*) SRC_PATH="stable/$PV/src/${P}.tar.bz2" ;;
- 5) SRC_URI="" # cvs ebuilds, no SRC_URI needed
+ 1*) SRC_PATH="stable/3.0.2/src/${P}.tar.bz2";; # backward compatibility for unmerging ebuilds
+ 2.2.2) SRC_PATH="Attic/2.2.2/src/${P}.tar.bz2" ;;
+ 3.1_alpha1) SRC_PATH="unstable/kde-3.1-alpha1/src/${P//3.1_alpha1/3.0.6}.tar.bz2" ;;
+ 3.1_beta1) SRC_PATH="unstable/kde-3.1-beta1/src/${P//3.1_beta1/3.0.7}.tar.bz2" ;;
+ 3.1_beta2) SRC_PATH="unstable/kde-3.1-beta2/src/${P//3.1_beta2/3.0.8}.tar.bz2" ;;
+ 3*) SRC_PATH="stable/$PV/src/${P}.tar.bz2" ;;
+ 5) SRC_URI="" # cvs ebuilds, no SRC_URI needed
debug-print "$ECLASS: finished, cvs detected, SRC_URI=$SRC_URI"
return 0 ;;
- *) debug-print "$ECLASS: Error: unrecognized version $PV, could not set SRC_URI" ;;
+ *) debug-print "$ECLASS: Error: unrecognized version $PV, could not set SRC_URI" ;;
esac
SRC_URI="mirror://kde/$SRC_PATH"