summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-09-29 07:45:09 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-09-29 07:45:09 +0000
commit1899fa7d88208f11e65915ed7c8df3a2ee89614d (patch)
tree21c078b0ae6af0ba7222a1b70ac2356ed11dc81e /games-action
parentVersion bumped, closing bug #62727. (Manifest recommit) (diff)
downloadgentoo-2-1899fa7d88208f11e65915ed7c8df3a2ee89614d.tar.gz
gentoo-2-1899fa7d88208f11e65915ed7c8df3a2ee89614d.tar.bz2
gentoo-2-1899fa7d88208f11e65915ed7c8df3a2ee89614d.zip
Changed sed script to edit proper file and closing bug #62877.
Diffstat (limited to 'games-action')
-rw-r--r--games-action/spacetripper-demo/ChangeLog6
-rw-r--r--games-action/spacetripper-demo/spacetripper-demo-1.ebuild14
2 files changed, 13 insertions, 7 deletions
diff --git a/games-action/spacetripper-demo/ChangeLog b/games-action/spacetripper-demo/ChangeLog
index d328be94a113..60f34c1055e8 100644
--- a/games-action/spacetripper-demo/ChangeLog
+++ b/games-action/spacetripper-demo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/spacetripper-demo
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/spacetripper-demo/ChangeLog,v 1.3 2004/09/05 07:51:48 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/spacetripper-demo/ChangeLog,v 1.4 2004/09/29 07:45:09 wolf31o2 Exp $
+
+ 29 Sep 2004; Chris Gianelloni <wolf31o2@gentoo.org>
+ spacetripper-demo-1.ebuild:
+ Changed sed script to edit proper file and closing bug #62877.
05 Sep 2004; Sven Wegener <swegener@gentoo.org> :
Fixed ChangeLog header.
diff --git a/games-action/spacetripper-demo/spacetripper-demo-1.ebuild b/games-action/spacetripper-demo/spacetripper-demo-1.ebuild
index 4c84b968be49..b6e1c20bf38a 100644
--- a/games-action/spacetripper-demo/spacetripper-demo-1.ebuild
+++ b/games-action/spacetripper-demo/spacetripper-demo-1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/spacetripper-demo/spacetripper-demo-1.ebuild,v 1.2 2004/06/24 21:59:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/spacetripper-demo/spacetripper-demo-1.ebuild,v 1.3 2004/09/29 07:45:09 wolf31o2 Exp $
inherit games eutils
@@ -14,6 +14,9 @@ SLOT="0"
KEYWORDS="-* x86"
IUSE=""
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
S=${WORKDIR}
src_unpack() {
@@ -22,15 +25,14 @@ src_unpack() {
}
src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
- dodir ${dir} ${GAMES_BINDIR}
+ dodir ${dir}
- cp -r preview run styles ${D}/${dir}/
+ cp -r preview run styles ${Ddir}
exeinto ${dir}
doexe bin/x86/*
- dosed "s:XYZZY:${dir}:" ${dir}/${PN}
- dosym ${dir}/spacetripperdemo ${GAMES_BINDIR}/${PN}
+ dosed "s:XYZZY:${dir}:" ${dir}/${MY_P}
+ dosym ${dir}/${MY_P} ${GAMES_BINDIR}/${PN}
insinto ${dir}
doins README license.txt icon.xpm