summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-03 07:49:45 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-03 07:49:45 +0000
commit6c116251b71703e9cbba5542c22105ba048d7a23 (patch)
tree22d60af7ebf998a7d4ec91eb79ed4ee2467ad7cf /games-action
parentVersion bump (#49138). (Manifest recommit) (diff)
downloadgentoo-2-6c116251b71703e9cbba5542c22105ba048d7a23.tar.gz
gentoo-2-6c116251b71703e9cbba5542c22105ba048d7a23.tar.bz2
gentoo-2-6c116251b71703e9cbba5542c22105ba048d7a23.zip
sed in unpack; fix use invocation; tidy
Diffstat (limited to 'games-action')
-rw-r--r--games-action/bzflag/ChangeLog5
-rw-r--r--games-action/bzflag/bzflag-1.10.4.ebuild28
2 files changed, 19 insertions, 14 deletions
diff --git a/games-action/bzflag/ChangeLog b/games-action/bzflag/ChangeLog
index 41ab6cf29dd9..211c43ad291f 100644
--- a/games-action/bzflag/ChangeLog
+++ b/games-action/bzflag/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/bzflag
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.9 2004/05/27 22:39:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/ChangeLog,v 1.10 2004/06/03 07:49:45 mr_bones_ Exp $
+
+ 03 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> bzflag-1.10.4.ebuild:
+ sed in unpack; fix use invocation; tidy
27 May 2004; Michael Sterrett <mr_bones_@gentoo.org>
bzflag-1.10.6.20040515.ebuild:
diff --git a/games-action/bzflag/bzflag-1.10.4.ebuild b/games-action/bzflag/bzflag-1.10.4.ebuild
index ccbbdedeaf13..1ed7d1182558 100644
--- a/games-action/bzflag/bzflag-1.10.4.ebuild
+++ b/games-action/bzflag/bzflag-1.10.4.ebuild
@@ -1,41 +1,43 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-1.10.4.ebuild,v 1.3 2004/04/19 21:24:35 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/bzflag/bzflag-1.10.4.ebuild,v 1.4 2004/06/03 07:49:45 mr_bones_ Exp $
inherit games
MY_P="${P}.20040125"
-S="${WORKDIR}/${PN}-1.10.4.20040125"
DESCRIPTION="OpenGL accelerated 3d tank combat simulator game"
HOMEPAGE="http://www.BZFlag.org/"
SRC_URI="mirror://sourceforge/bzflag/${MY_P}.tar.bz2"
-IUSE=""
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 ppc amd64"
+IUSE=""
DEPEND="virtual/opengl"
-src_compile () {
- if [ "`use amd64`" ]; then
- sed -e "s/-mcpu=\$host_cpu//" configure > configure.new
- mv configure.new configure
+S="${WORKDIR}/${PN}-1.10.4.20040125"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if use amd64 ; then
+ sed -i \
+ -e "s/-mcpu=\$host_cpu//" configure \
+ || die "sed failed"
chmod +x configure
fi
- egamesconf || die
- emake || die
}
src_install () {
- make DESTDIR=${D} install || die "make install failed"
- dodoc AUTHORS README.UNIX TODO README ChangeLog BUGS PORTING || \
- die "dodoc failed"
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README.UNIX TODO README ChangeLog BUGS PORTING
prepgamesdirs
}
pkg_postinst() {
games_pkg_postinst
+ echo
ewarn "This version of ${PN} breaks compatibility with all previous releases"
echo
}