summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-10-22 21:21:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-10-22 21:21:09 +0000
commitdff5f16b67c8da894aeab51b00b76b827e3b2e87 (patch)
tree363cb56108d167e5ecbe7d8bdc56db86255d0008 /games-strategy
parentinitial commit (bug 30603) (diff)
downloadgentoo-2-dff5f16b67c8da894aeab51b00b76b827e3b2e87.tar.gz
gentoo-2-dff5f16b67c8da894aeab51b00b76b827e3b2e87.tar.bz2
gentoo-2-dff5f16b67c8da894aeab51b00b76b827e3b2e87.zip
initial commit (bug 30603)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog9
-rw-r--r--games-strategy/wesnoth/Manifest4
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.4.81
-rw-r--r--games-strategy/wesnoth/metadata.xml9
-rw-r--r--games-strategy/wesnoth/wesnoth-0.4.8.ebuild34
5 files changed, 56 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
new file mode 100644
index 000000000000..8e9e720d5bf5
--- /dev/null
+++ b/games-strategy/wesnoth/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for games-strategy/wesnoth
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.1 2003/10/22 21:21:07 mr_bones_ Exp $
+
+*wesnoth-0.4.8 (22 Oct 2003)
+
+ 22 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-0.4.8.ebuild:
+ initial commit; ebuild based on the one provided by Giblets via bug 30603
+
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index 96adcced8893..c789286d7873 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,2 +1,4 @@
-MD5 292c797279011cda4928915ba98d5449 wesnoth-0.4.8.ebuild 825
+MD5 780c10b9072e511acd2797e086ddffc6 wesnoth-0.4.8.ebuild 1042
+MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 cfd57ea4f2b243739df6d419592647f7 ChangeLog 413
MD5 12449f4d45609424ab20eb79f5f77baf files/digest-wesnoth-0.4.8 66
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.4.8 b/games-strategy/wesnoth/files/digest-wesnoth-0.4.8
new file mode 100644
index 000000000000..fc4d6e038ad0
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.4.8
@@ -0,0 +1 @@
+MD5 8778b02dee552ea7f3a954bee44cf363 wesnoth-0.4.8.tar.gz 5437779
diff --git a/games-strategy/wesnoth/metadata.xml b/games-strategy/wesnoth/metadata.xml
new file mode 100644
index 000000000000..1cef6e243af3
--- /dev/null
+++ b/games-strategy/wesnoth/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>games@gentoo.org</email>
+<name>Games Team</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-strategy/wesnoth/wesnoth-0.4.8.ebuild b/games-strategy/wesnoth/wesnoth-0.4.8.ebuild
new file mode 100644
index 000000000000..09ab21853d57
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.4.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.4.8.ebuild,v 1.1 2003/10/22 21:21:07 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="http://www.wesnoth.org/files/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-ttf-2.0
+ virtual/x11"
+
+src_compile() {
+ CXXFLAGS="${CXXFLAGS} -DWESNOTH_PATH=\\\"${GAMES_DATADIR}/wesnoth\\\""
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin wesnoth || die "dogamesbin failed"
+ dodoc MANUAL changelog || die "dodoc failed"
+ dodir ${GAMES_DATADIR}/wesnoth || die "dodir failed"
+ cp -r data fonts images music sounds \
+ ${D}${GAMES_DATADIR}/wesnoth/ || die "cp failed"
+ find ${D}${GAMES_DATADIR} -type f -exec chmod a-x \{\} \;
+ prepgamesdirs
+}