summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-10-13 07:51:01 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-10-13 07:51:01 +0000
commitae9c41872e8f2afd42ff7beb7d06326234353c3a (patch)
tree903a1c9947801b128f9c734f4f03379301aaba7b /kde-base/kig
parentUpdate mask for kig. (diff)
downloadgentoo-2-ae9c41872e8f2afd42ff7beb7d06326234353c3a.tar.gz
gentoo-2-ae9c41872e8f2afd42ff7beb7d06326234353c3a.tar.bz2
gentoo-2-ae9c41872e8f2afd42ff7beb7d06326234353c3a.zip
Provide a version of kig that does not depend on boost.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'kde-base/kig')
-rw-r--r--kde-base/kig/ChangeLog8
-rw-r--r--kde-base/kig/files/digest-kig-3.4.3-r101
-rw-r--r--kde-base/kig/kig-3.4.3-r10.ebuild19
-rw-r--r--kde-base/kig/kig-3.4.3.ebuild12
4 files changed, 35 insertions, 5 deletions
diff --git a/kde-base/kig/ChangeLog b/kde-base/kig/ChangeLog
index bb4d67d174e5..ea1124a4bb18 100644
--- a/kde-base/kig/ChangeLog
+++ b/kde-base/kig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kig
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/ChangeLog,v 1.22 2005/10/13 00:10:01 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/ChangeLog,v 1.23 2005/10/13 07:51:01 greg_g Exp $
+
+*kig-3.4.3-r10 (13 Oct 2005)
+
+ 13 Oct 2005; Gregorio Guidi <greg_g@gentoo.org> kig-3.4.3.ebuild,
+ +kig-3.4.3-r10.ebuild:
+ Provide a version of kig that does not depend on boost.
*kig-3.4.3 (13 Oct 2005)
diff --git a/kde-base/kig/files/digest-kig-3.4.3-r10 b/kde-base/kig/files/digest-kig-3.4.3-r10
new file mode 100644
index 000000000000..4e5b4661f69a
--- /dev/null
+++ b/kde-base/kig/files/digest-kig-3.4.3-r10
@@ -0,0 +1 @@
+MD5 9f4059beb1c3495973dd80d11bcae462 kdeedu-3.4.3.tar.bz2 23983295
diff --git a/kde-base/kig/kig-3.4.3-r10.ebuild b/kde-base/kig/kig-3.4.3-r10.ebuild
new file mode 100644
index 000000000000..281768986159
--- /dev/null
+++ b/kde-base/kig/kig-3.4.3-r10.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/kig-3.4.3-r10.ebuild,v 1.1 2005/10/13 07:51:01 greg_g Exp $
+KMNAME=kdeedu
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE Interactive Geometry tool"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kig-scripting"
+
+DEPEND="kig-scripting? ( >=dev-libs/boost-1.32 )"
+
+src_compile() {
+ myconf="${myconf} $(use_enable kig-scripting kig-python-scripting)"
+
+ kde_src_compile
+}
diff --git a/kde-base/kig/kig-3.4.3.ebuild b/kde-base/kig/kig-3.4.3.ebuild
index 6bf562db5bb0..a758803afa46 100644
--- a/kde-base/kig/kig-3.4.3.ebuild
+++ b/kde-base/kig/kig-3.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/kig-3.4.3.ebuild,v 1.1 2005/10/13 00:10:01 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/kig-3.4.3.ebuild,v 1.2 2005/10/13 07:51:01 greg_g Exp $
KMNAME=kdeedu
MAXKDEVER=$PV
KM_DEPRANGE="$PV $MAXKDEVER"
@@ -8,11 +8,15 @@ inherit kde-meta
DESCRIPTION="KDE Interactive Geometry tool"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="kig-scripting"
-DEPEND="kig-scripting? ( >=dev-libs/boost-1.32 )"
+#IUSE="kig-scripting"
+IUSE=""
+
+# Waiting for stabilization.
+#DEPEND="kig-scripting? ( >=dev-libs/boost-1.32 )"
src_compile() {
- myconf="${myconf} $(use_enable kig-scripting kig-python-scripting)"
+ #myconf="${myconf} $(use_enable kig-scripting kig-python-scripting)"
+ myconf="${myconf} --disable-kig-python-scripting)"
kde_src_compile
}