summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2004-12-21 12:50:09 +0000
committerTom William Payne <twp@gentoo.org>2004-12-21 12:50:09 +0000
commit165c62e1b49d4edb3cbb21bdb6cea3825c7a1c61 (patch)
tree9af4b482b39008048cbaa9b218bafa592eb7c041 /media-libs
parentRevision for missing dep (Manifest recommit) (diff)
downloadgentoo-2-165c62e1b49d4edb3cbb21bdb6cea3825c7a1c61.tar.gz
gentoo-2-165c62e1b49d4edb3cbb21bdb6cea3825c7a1c61.tar.bz2
gentoo-2-165c62e1b49d4edb3cbb21bdb6cea3825c7a1c61.zip
Patch makefile, respect EXTRA_ECONF, install doc. Bug # 75008. Thanks yselkowitz.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/glitz/ChangeLog7
-rw-r--r--media-libs/glitz/files/glitz-0.2.3-link.patch19
-rw-r--r--media-libs/glitz/glitz-0.2.3.ebuild7
3 files changed, 30 insertions, 3 deletions
diff --git a/media-libs/glitz/ChangeLog b/media-libs/glitz/ChangeLog
index 4287c45dc23e..cafc4e5eae1c 100644
--- a/media-libs/glitz/ChangeLog
+++ b/media-libs/glitz/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/glitz
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/glitz/ChangeLog,v 1.2 2004/12/20 13:01:20 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glitz/ChangeLog,v 1.3 2004/12/21 12:50:09 twp Exp $
+
+ 21 Dec 2004; Tom Payne <twp@gentoo.org> +files/glitz-0.2.3-link.patch,
+ glitz-0.2.3.ebuild:
+ Patch makefile, respect EXTRA_ECONF, install doc. Bug # 75008. Thanks
+ yselkowitz.
20 Dec 2004; Tom Payne <twp@gentoo.org> glitz-0.2.3.ebuild:
Removed unescessary assignment to $S.
diff --git a/media-libs/glitz/files/glitz-0.2.3-link.patch b/media-libs/glitz/files/glitz-0.2.3-link.patch
new file mode 100644
index 000000000000..1446e6c2b815
--- /dev/null
+++ b/media-libs/glitz/files/glitz-0.2.3-link.patch
@@ -0,0 +1,19 @@
+diff -Naur glitz-0.2.3/src/Makefile.am glitz/src/Makefile.am
+--- glitz-0.2.3/src/Makefile.am 2004-09-03 16:27:58.000000000 +0200
++++ glitz/src/Makefile.am 2004-12-21 13:39:31.655976048 +0100
+@@ -63,7 +63,7 @@
+ glitz_glxint.h
+ libglitz_glx_la_LDFLAGS = -version-info @VERSION_INFO@ -no-undefined
+ libglitz_glx_la_CFLAGS = $(GLX_CFLAGS)
+-libglitz_glx_la_LIBADD = -lglitz $(GLX_LIBS)
++libglitz_glx_la_LIBADD = libglitz.la $(GLX_LIBS)
+ endif
+
+ if GLITZ_BUILD_AGL_BACKEND
+@@ -81,5 +81,5 @@
+ glitz_aglint.h
+ libglitz_agl_la_LDFLAGS = -version-info @VERSION_INFO@
+ libglitz_agl_la_CFLAGS = $(AGL_CFLAGS)
+-libglitz_agl_la_LIBADD = -lglitz $(AGL_LIBS)
++libglitz_agl_la_LIBADD = libglitz.la $(AGL_LIBS)
+ endif
diff --git a/media-libs/glitz/glitz-0.2.3.ebuild b/media-libs/glitz/glitz-0.2.3.ebuild
index c039e24818c6..b86deb4479b8 100644
--- a/media-libs/glitz/glitz-0.2.3.ebuild
+++ b/media-libs/glitz/glitz-0.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/glitz/glitz-0.2.3.ebuild,v 1.2 2004/12/20 13:01:20 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glitz/glitz-0.2.3.ebuild,v 1.3 2004/12/21 12:50:09 twp Exp $
inherit eutils
@@ -15,16 +15,19 @@ IUSE=""
DEPEND="virtual/opengl"
src_compile() {
+ epatch ${FILESDIR}/glitz-0.2.3-link.patch
WANT_AUTOMAKE=1.8 ./autogen.sh --prefix=/usr \
--host=${CHOST} \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--datadir=/usr/share \
--sysconfdir=/etc \
- --localstatedir=/var/lib || die "autogen.sh failed"
+ --localstatedir=/var/lib
+ ${EXTRA_ECONF} || die "autogen.sh failed"
emake || die "emake failed"
}
src_install() {
make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog README TODO
}