summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-01-15 22:18:10 +0000
committerAron Griffis <agriffis@gentoo.org>2004-01-15 22:18:10 +0000
commit691a42cc35b4ee6568f3a37699a9d74ff2716de2 (patch)
treeef8110e15192d8be8b353d9f7fafbf8f91d4baee /net-fs
parentAdded fonts herd to metadata.xml (diff)
downloadgentoo-2-691a42cc35b4ee6568f3a37699a9d74ff2716de2.tar.gz
gentoo-2-691a42cc35b4ee6568f3a37699a9d74ff2716de2.tar.bz2
gentoo-2-691a42cc35b4ee6568f3a37699a9d74ff2716de2.zip
Fix bug 30486 by refraining from overwriting /var/lib/nfs/*
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/ChangeLog5
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.0.6.ebuild21
2 files changed, 24 insertions, 2 deletions
diff --git a/net-fs/nfs-utils/ChangeLog b/net-fs/nfs-utils/ChangeLog
index 147c171d7a1d..d9026a88a1dd 100644
--- a/net-fs/nfs-utils/ChangeLog
+++ b/net-fs/nfs-utils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-fs/nfs-utils
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.30 2004/01/14 22:53:02 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.31 2004/01/15 22:18:10 agriffis Exp $
+
+ 15 Jan 2004; Aron Griffis <agriffis@gentoo.org> nfs-utils-1.0.6.ebuild:
+ Fix bug 30486 by refraining from overwriting /var/lib/nfs/*
14 Jan 2004; Martin Holzer <mholzer@gentoo.org> files/nfs.confd:
removing quota entry from conf.d
diff --git a/net-fs/nfs-utils/nfs-utils-1.0.6.ebuild b/net-fs/nfs-utils/nfs-utils-1.0.6.ebuild
index a09eb9958176..b0d702e6c6ae 100644
--- a/net-fs/nfs-utils/nfs-utils-1.0.6.ebuild
+++ b/net-fs/nfs-utils/nfs-utils-1.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.6.ebuild,v 1.8 2004/01/14 22:53:02 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.6.ebuild,v 1.9 2004/01/15 22:18:10 agriffis Exp $
IUSE="tcpd"
@@ -34,6 +34,12 @@ src_install() {
make install install_prefix=${D} MANDIR=${D}/usr/share/man \
|| die "Failed to install"
+ # Don't overwrite existing xtab/etab, install the original
+ # versions somewhere safe... more info in pkg_postinst
+ mkdir -p ${D}/usr/lib/nfs
+ mv ${D}/var/lib/nfs/* ${D}/usr/lib/nfs
+ keepdir /var/lib/nfs
+
# Install some client-side binaries in /sbin
mkdir ${D}/sbin
mv ${D}/usr/sbin/rpc.{lockd,statd} ${D}/sbin
@@ -52,6 +58,18 @@ src_install() {
}
pkg_postinst() {
+ # Install default xtab and friends if there's none existing.
+ # In src_install we put them in /usr/lib/nfs for safe-keeping, but
+ # the daemons actually use the files in /var/lib/nfs. This fixes
+ # bug 30486
+ local f
+ for f in ${ROOT}/usr/lib/nfs/*; do
+ [[ -f ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
+ einfo "Copying default ${f##*/} from /usr/lib/nfs to /var/lib/nfs"
+ cp -a ${f} ${ROOT}/var/lib/nfs/
+ done
+
+ echo
einfo "NFS V2 and V3 servers now default to \"sync\" IO if ${P}"
einfo "(or later) is installed."
einfo "More info at ${HOMEPAGE} (see questions 5, 12, 13, and 14)."
@@ -61,6 +79,7 @@ pkg_postinst() {
ewarn "export list, thus assuming the default behavior, a warning will"
ewarn "be generated at export time."
echo
+
# Running depscan since we introduced /etc/init.d/{portmap,nfs}
/etc/init.d/depscan.sh
}