summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-11-30 09:49:41 +0000
committerChris White <chriswhite@gentoo.org>2005-11-30 09:49:41 +0000
commit14afc7ac4f63d55e776e6880f47f1c635021b0cc (patch)
treec935d59c46497de060f501912e5e27df91538d54 /net-irc/vyqchat/vyqchat-0.1.1.ebuild
parent(no commit message) (diff)
downloadgentoo-2-14afc7ac4f63d55e776e6880f47f1c635021b0cc.tar.gz
gentoo-2-14afc7ac4f63d55e776e6880f47f1c635021b0cc.tar.bz2
gentoo-2-14afc7ac4f63d55e776e6880f47f1c635021b0cc.zip
*** empty log message ***
Diffstat (limited to 'net-irc/vyqchat/vyqchat-0.1.1.ebuild')
-rw-r--r--net-irc/vyqchat/vyqchat-0.1.1.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/net-irc/vyqchat/vyqchat-0.1.1.ebuild b/net-irc/vyqchat/vyqchat-0.1.1.ebuild
index 32ceb93be130..b3c78c15b64a 100644
--- a/net-irc/vyqchat/vyqchat-0.1.1.ebuild
+++ b/net-irc/vyqchat/vyqchat-0.1.1.ebuild
@@ -1,32 +1,29 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/vyqchat/vyqchat-0.1.1.ebuild,v 1.1 2003/10/05 17:40:22 gregf Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/vyqchat/vyqchat-0.1.1.ebuild,v 1.1.1.1 2005/11/30 09:48:56 chriswhite Exp $
DESCRIPTION="QT based Vypress Chat clone for X."
HOMEPAGE="http://linux.bydg.org/~yogin/"
SRC_URI="http://linux.bydg.org/~yogin/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE="arts"
-DEPEND=">=qt-3.0
- arts? ( kde-base/arts )"
-RDEPEND="${DEPEND}"
-S=${WORKDIR}/${P}
+DEPEND="=x11-libs/qt-3*
+ arts? ( kde-base/arts )"
src_compile() {
- local myconf
- use arts && myconf="--with-arts"
- ./configure --host=${CHOST} \
- --prefix=/usr --infodir=/usr/share/info \
- --mandir=/usr/share/man --with-x \
- --with-Qt-dir=/usr/qt/3 ${myconf} || die "./configure failed"
- emake || die
+ econf \
+ --with-x \
+ --with-Qt-dir=/usr/qt/3 \
+ $(use_with arts) \
+ || die "econf failed"
+ emake || die "emake failed"
}
src_install() {
- einstall || die
- dodoc README THANKS NEWS
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc README THANKS NEWS || die "dodoc failed"
}