summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2004-12-25 13:09:52 +0000
committerTom Martin <slarti@gentoo.org>2004-12-25 13:09:52 +0000
commit7ac2fafdfb87a5357fd6da49ed729bae28b20468 (patch)
treeed6ee0d86d7da7a1da6b069827e06abdc3e4bd93 /net-libs/libgsasl/libgsasl-0.2.3.ebuild
parentfixing kernel masking. (diff)
downloadgentoo-2-7ac2fafdfb87a5357fd6da49ed729bae28b20468.tar.gz
gentoo-2-7ac2fafdfb87a5357fd6da49ed729bae28b20468.tar.bz2
gentoo-2-7ac2fafdfb87a5357fd6da49ed729bae28b20468.zip
Version bump -> 0.2.3, stabilise 0.2.0 on amd64
Diffstat (limited to 'net-libs/libgsasl/libgsasl-0.2.3.ebuild')
-rw-r--r--net-libs/libgsasl/libgsasl-0.2.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/libgsasl/libgsasl-0.2.3.ebuild b/net-libs/libgsasl/libgsasl-0.2.3.ebuild
new file mode 100644
index 000000000000..1657f3e79a08
--- /dev/null
+++ b/net-libs/libgsasl/libgsasl-0.2.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgsasl/libgsasl-0.2.3.ebuild,v 1.1 2004/12/25 13:09:52 slarti Exp $
+
+DESCRIPTION="The GNU SASL library"
+HOMEPAGE="http://www.gnu.org/software/gsasl/"
+SRC_URI="ftp://alpha.gnu.org/pub/gnu/gsasl/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+# TODO: check http://www.gnu.org/software/gsasl/#dependencies for more
+# optional external libraries.
+# KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="kerberos nls static"
+PROVIDE="virtual/gsasl"
+DEPEND="virtual/libc
+ nls? ( sys-devel/gettext )
+ kerberos? ( virtual/krb5 )"
+RDEPEND="${DEPEND}
+ !virtual/gsasl"
+
+src_compile() {
+ econf \
+ $(use_enable kerberos gssapi) \
+ $(use_enable nls) \
+ $(use_enable static) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README README-alpha THANKS
+}