summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-23 00:54:50 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-23 00:54:50 +0000
commit46ab5aa317f70f1a0974245e0e06783d2af00297 (patch)
tree64ac97931b16b1dfd18067229bbd6a7f042663a5 /net-libs/libnet
parentversion bump, removing unnecessary src_compile (diff)
downloadgentoo-2-46ab5aa317f70f1a0974245e0e06783d2af00297.tar.gz
gentoo-2-46ab5aa317f70f1a0974245e0e06783d2af00297.tar.bz2
gentoo-2-46ab5aa317f70f1a0974245e0e06783d2af00297.zip
Add patches from debian to generate a libnet.so for linking #82926.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-libs/libnet')
-rw-r--r--net-libs/libnet/ChangeLog9
-rw-r--r--net-libs/libnet/files/digest-libnet-1.1.2.1-r11
-rw-r--r--net-libs/libnet/files/libnet-1.1.2.1-autotools.patch79
-rw-r--r--net-libs/libnet/files/libnet-1.1.2.1-fix-chksum.patch27
-rw-r--r--net-libs/libnet/libnet-1.1.2.1-r1.ebuild42
5 files changed, 157 insertions, 1 deletions
diff --git a/net-libs/libnet/ChangeLog b/net-libs/libnet/ChangeLog
index ccabe482e186..ad9c92ed4f71 100644
--- a/net-libs/libnet/ChangeLog
+++ b/net-libs/libnet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libnet
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.37 2005/01/11 14:10:22 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.38 2005/03/23 00:54:50 vapier Exp $
+
+*libnet-1.1.2.1-r1 (23 Mar 2005)
+
+ 23 Mar 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/libnet-1.1.2.1-autotools.patch,
+ +files/libnet-1.1.2.1-fix-chksum.patch, +libnet-1.1.2.1-r1.ebuild:
+ Add patches from debian to generate a libnet.so for linking #82926.
11 Jan 2005; Daniel Black <dragonheart@gentoo.org> files/1.0.2a-slot.patch:
expanded patch to fix selftest routine.
diff --git a/net-libs/libnet/files/digest-libnet-1.1.2.1-r1 b/net-libs/libnet/files/digest-libnet-1.1.2.1-r1
new file mode 100644
index 000000000000..c2f0e935f16a
--- /dev/null
+++ b/net-libs/libnet/files/digest-libnet-1.1.2.1-r1
@@ -0,0 +1 @@
+MD5 be845c41170d72c7db524f3411b50256 libnet-1.1.2.1.tar.gz 1021236
diff --git a/net-libs/libnet/files/libnet-1.1.2.1-autotools.patch b/net-libs/libnet/files/libnet-1.1.2.1-autotools.patch
new file mode 100644
index 000000000000..0f4c65094dba
--- /dev/null
+++ b/net-libs/libnet/files/libnet-1.1.2.1-autotools.patch
@@ -0,0 +1,79 @@
+Patch ripped from Debian. Add support for building a shared
+libnet library (for PIC loving). Also fixes typo for installing
+the libnet-config script.
+
+http://bugs.gentoo.org/show_bug.cgi?id=82926
+
+--- libnet-1.1.2.1.orig/src/Makefile.am
++++ libnet-1.1.2.1/src/Makefile.am
+@@ -8,9 +8,9 @@
+
+ include $(top_srcdir)/Makefile.am.common
+
+-lib_LIBRARIES = libnet.a
++lib_LTLIBRARIES = libnet.la
+
+-libnet_a_SOURCES = libnet_asn1.c \
++libnet_la_SOURCES = libnet_asn1.c \
+ libnet_build_802.1q.c \
+ libnet_build_802.1x.c \
+ libnet_build_802.2.c \
+@@ -57,15 +57,20 @@
+ libnet_version.c \
+ libnet_write.c
+
+-EXTRA_libnet_a_SOURCES = libnet_link_bpf.c \
+- libnet_link_dlpi.c \
+- libnet_link_linux.c \
+- libnet_link_nit.c \
+- libnet_link_none.c \
+- libnet_link_pf.c \
+- libnet_link_snit.c \
+- libnet_link_snoop.c \
+- libnet_link_win32.c
+-
+-libnet_a_LIBADD = @LIBOBJS@
++libnet_la_LIBADD = @LTLIBOBJS@
+
++# Here are a set of rules to help you update your library version
++# information:
++#
++# 1. If the library source code has changed at all since the last
++# update, then increment REVISION (`C:R:A' becomes `C:r+1:A').
++#
++# 2. If any interfaces have been added, removed, or changed since the
++# last update, increment CURRENT, and set REVISION to 0.
++#
++# 3. If any interfaces have been added since the last public release,
++# then increment AGE.
++#
++# 4. If any interfaces have been removed since the last public release,
++# then set AGE to 0.
++libnet_la_LDFLAGS = -version-info 4:0:3 # CURRENT[:REVISION[:AGE]]
+--- libnet-1.1.2.1.orig/configure.in
++++ libnet-1.1.2.1/configure.in
+@@ -21,7 +21,7 @@
+ dnl
+ AC_PROG_CC
+ AC_PROG_INSTALL
+-AC_PROG_RANLIB
++AC_PROG_LIBTOOL
+
+ AC_CHECK_HEADERS(sys/sockio.h)
+
+--- libnet-1.1.2.1.orig/Makefile.am
++++ libnet-1.1.2.1/Makefile.am
+@@ -12,4 +12,4 @@
+
+ EXTRA_DIST = Makefile.am.common
+
+-bin_scripts = libnet-config
++bin_SCRIPTS = libnet-config
+--- libnet-1.1.2.1.orig/sample/Makefile.am
++++ libnet-1.1.2.1/sample/Makefile.am
+@@ -60,4 +60,4 @@
+ ip_link_SOURCES = ip_link.c
+ sebek_SOURCES = sebek.c
+
+-LDADD = $(top_srcdir)/src/libnet.a
++LDADD = $(top_srcdir)/src/libnet.la
diff --git a/net-libs/libnet/files/libnet-1.1.2.1-fix-chksum.patch b/net-libs/libnet/files/libnet-1.1.2.1-fix-chksum.patch
new file mode 100644
index 000000000000..e6f9bbc6dd21
--- /dev/null
+++ b/net-libs/libnet/files/libnet-1.1.2.1-fix-chksum.patch
@@ -0,0 +1,27 @@
+Fix a bug in chksum calculation for odd sized UDP packets.
+
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=284729
+
+--- libnet-1.1.2.1/src/libnet_checksum.c
++++ libnet-1.1.2.1/src/libnet_checksum.c
+@@ -42,8 +42,10 @@
+ libnet_in_cksum(u_int16_t *addr, int len)
+ {
+ int sum;
++ u_int16_t last_byte;
+
+ sum = 0;
++ last_byte = 0;
+
+ while (len > 1)
+ {
+@@ -52,7 +54,8 @@
+ }
+ if (len == 1)
+ {
+- sum += *(u_int16_t *)addr;
++ *(u_int8_t*)&last_byte = *(u_int8_t*)addr;
++ sum += last_byte;
+ }
+
+ return (sum);
diff --git a/net-libs/libnet/libnet-1.1.2.1-r1.ebuild b/net-libs/libnet/libnet-1.1.2.1-r1.ebuild
new file mode 100644
index 000000000000..91fd7d38b5b8
--- /dev/null
+++ b/net-libs/libnet/libnet-1.1.2.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.1.2.1-r1.ebuild,v 1.1 2005/03/23 00:54:50 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="library to provide an API for commonly used low-level network functions (mainly packet injection)"
+HOMEPAGE="http://www.packetfactory.net/libnet/"
+SRC_URI="http://www.packetfactory.net/libnet/dist/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~s390 ~sh ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="sys-devel/autoconf"
+RDEPEND=""
+
+S=${WORKDIR}/libnet
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fix-chksum.patch
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ libtoolize --copy --force && \
+ aclocal && \
+ autoconf && \
+ automake || die "autotools failed"
+}
+
+src_install(){
+ make DESTDIR="${D}" install || die "Failed to install"
+
+ doman doc/man/man3/*.3
+ dodoc VERSION README doc/*
+ if use doc ; then
+ dohtml -r doc/html/*
+ docinto sample
+ dodoc sample/*.[ch]
+ fi
+}