summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <lamer@gentoo.org>2002-07-17 03:11:56 +0000
committerBen Lutgens <lamer@gentoo.org>2002-07-17 03:11:56 +0000
commitb6b87945077f2014ae215a640b9e8edc861014aa (patch)
tree5a8c61e88addf7b9f18ebd59ce3a76c96452bf79 /net-mail/fetchmail
parentrepoman'd (diff)
downloadgentoo-2-b6b87945077f2014ae215a640b9e8edc861014aa.tar.gz
gentoo-2-b6b87945077f2014ae215a640b9e8edc861014aa.tar.bz2
gentoo-2-b6b87945077f2014ae215a640b9e8edc861014aa.zip
added a depend on ypbind for autofs
updated the HOMEPAGE for ppp disabled use of socks5 USE var in bitchx cause it's b0rken added a fetchmail system wide init script, revved the package and masked it added mailman to the tree and masked it, hope to hell i didn't miss anything. Sorry daniel, can't run repoman this high-up in the tree, you'll have to take my word for it I ran it individually on each package i touched ;-)
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/ChangeLog13
-rw-r--r--net-mail/fetchmail/fetchmail-5.9.11-r1.ebuild63
-rw-r--r--net-mail/fetchmail/files/fetchmail24
3 files changed, 98 insertions, 2 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index 0b8fbd81fd0e..2b9fb8b9dec5 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,15 @@
-# ChangeLog for net-mail/fetchmail
+# ChangeLog for net-mailfetchmailChangeLog/
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.2 2002/02/15 05:02:04 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.3 2002/07/17 03:11:56 lamer Exp $
+
+*fetchmail-5.9.11-r1 (16 Jul 2002)
+
+ 16 Jul 2002; Ben Lutgens <lamer@gentoo.org> fetchmail-5.9.11-r1,
+ files/fetchmail :
+
+ Added an initscript, revved the minor version to -r1 for masking purposes,
+ masked. Fixes bug 4415
+
*fetchmail-5.9.7 (14 Feb 2002)
diff --git a/net-mail/fetchmail/fetchmail-5.9.11-r1.ebuild b/net-mail/fetchmail/fetchmail-5.9.11-r1.ebuild
new file mode 100644
index 000000000000..7a8303fef188
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-5.9.11-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-5.9.11-r1.ebuild,v 1.1 2002/07/17 03:11:56 lamer Exp $
+
+DESCRIPTION="Fetchmail is a full-featured remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
+SRC_URI="http://www.tuxedo.org/~esr/fetchmail/${P}.tar.gz"
+S="${WORKDIR}/${P}"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use ssl && myconf="${myconf} --with-ssl=/usr"
+ use nls || myconf="${myconf} --disable-nls"
+ # This needs inet6-apps, which we don't have
+ #use ipv6 && myconf="{myconf} --enable-inet6"
+
+ ./configure --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host="${CHOST}" \
+ ${myconf} \
+ || die "Configuration failed."
+ emake || die "Compilation failed."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dohtml *.html
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+ docinto contrib
+
+ exeinto /etc/init.d
+ doexe file/fetchmail
+
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+}
diff --git a/net-mail/fetchmail/files/fetchmail b/net-mail/fetchmail/files/fetchmail
new file mode 100644
index 000000000000..27226f89c6c5
--- /dev/null
+++ b/net-mail/fetchmail/files/fetchmail
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+
+checkconfig() {
+ if [ ! -f /etc/fetchmailrc ]; then
+ eerror "Configuration file /etc/fetchmailrc not found"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting fetchmail"
+ start-stop-daemon --start --quiet --exec /usr/bin/fetchmail \
+ -- -f /etc/fetchmailrc
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping fetchmail"
+ start-stop-daemon --stop --quiet --pidfile /var/run/fetchmail.pid
+ eend ${?}
+}
+