summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-02-08 23:57:01 +0000
committerMarius Mauch <genone@gentoo.org>2004-02-08 23:57:01 +0000
commite2f8b32c438f08aa44c1e46717059e359f5f0216 (patch)
tree2bd38edc7b15fd4ecc429fdf922724c58af5637f /net-mail/sylpheed-claws
parentamd64 (diff)
downloadgentoo-2-e2f8b32c438f08aa44c1e46717059e359f5f0216.tar.gz
gentoo-2-e2f8b32c438f08aa44c1e46717059e359f5f0216.tar.bz2
gentoo-2-e2f8b32c438f08aa44c1e46717059e359f5f0216.zip
version bump
Diffstat (limited to 'net-mail/sylpheed-claws')
-rw-r--r--net-mail/sylpheed-claws/ChangeLog7
-rw-r--r--net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.9.92
-rw-r--r--net-mail/sylpheed-claws/sylpheed-claws-0.9.9.ebuild143
3 files changed, 151 insertions, 1 deletions
diff --git a/net-mail/sylpheed-claws/ChangeLog b/net-mail/sylpheed-claws/ChangeLog
index a20a79f07228..b25a8b51c3cc 100644
--- a/net-mail/sylpheed-claws/ChangeLog
+++ b/net-mail/sylpheed-claws/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/sylpheed-claws
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/ChangeLog,v 1.63 2004/01/16 22:18:34 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/ChangeLog,v 1.64 2004/02/08 23:57:01 genone Exp $
+
+*sylpheed-claws-0.9.9 (09 Feb 2004)
+
+ 09 Feb 2004; Marius Mauch <genone@gentoo.org> sylpheed-claws-0.9.9.ebuild:
+ version bump
16 Jan 2004; Marius Mauch <genone@gentoo.org>
sylpheed-claws-0.8.11.ebuild, sylpheed-claws-0.9.0-r1.ebuild,
diff --git a/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.9.9 b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.9.9
new file mode 100644
index 000000000000..ff7ee8f4cd0b
--- /dev/null
+++ b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.9.9
@@ -0,0 +1,2 @@
+MD5 9068192f009fb8240be6e9222ff27999 sylpheed-0.9.9claws.tar.bz2 2960914
+MD5 76f1a9069271ecef0a4c2d463c58708d ghostscript-viewer-0.6.tar.bz2 244060
diff --git a/net-mail/sylpheed-claws/sylpheed-claws-0.9.9.ebuild b/net-mail/sylpheed-claws/sylpheed-claws-0.9.9.ebuild
new file mode 100644
index 000000000000..f840925a838f
--- /dev/null
+++ b/net-mail/sylpheed-claws/sylpheed-claws-0.9.9.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/sylpheed-claws-0.9.9.ebuild,v 1.1 2004/02/08 23:57:01 genone Exp $
+
+IUSE="nls gnome xface dillo crypt spell imlib ssl ldap ipv6 pda clamav pdflib"
+
+inherit eutils
+
+GS_PN=ghostscript-viewer
+GS_PV=0.6
+MY_GS=${GS_PN}-${GS_PV}
+MY_P="sylpheed-${PV}claws"
+S=${WORKDIR}/${MY_P}
+S2=${S}/src/plugins/${MY_GS}
+DESCRIPTION="Bleeding edge version of Sylpheed"
+HOMEPAGE="http://sylpheed-claws.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2
+ pdflib? ( mirror://sourceforge/${PN}/${MY_GS}.tar.bz2 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=">=sys-apps/sed-4
+ =x11-libs/gtk+-1.2*
+ pda? ( >=app-pda/jpilot-0.99 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( =app-crypt/gpgme-0.3.14 )
+ dillo? ( net-www/dillo )
+ gnome? ( >=media-libs/gdk-pixbuf-0.16 )
+ imlib? ( >=media-libs/imlib-1.9.10 )
+ spell? ( virtual/aspell-dict )
+ xface? ( >=media-libs/compface-1.4 )
+ pdflib? ( virtual/ghostscript )
+ nls? ( >=sys-devel/gettext-0.12 )"
+
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ net-mail/metamail
+ x11-misc/shared-mime-info"
+
+PROVIDE="virtual/sylpheed"
+
+src_unpack() {
+ unpack ${A}
+
+ mv ${WORKDIR}/${MY_GS} ${S}/src/plugins
+
+ # Change package name to sylpheed-claws ...
+ for i in `find ${S}/ -name 'configure*'`; do
+ sed -i "s/PACKAGE\=sylpheed/PACKAGE\=sylpheed-claws/" ${i}
+ done
+
+ # use shared-mime-info
+ cd ${S}/src
+ epatch ${FILESDIR}/procmime.patch
+
+ # procmime API was changed between 0.9.6 and 0.9.7,
+ # default Makefile uses installed (=old) headers
+ if use pdflib; then
+ cd ${S2}
+ epatch ${FILESDIR}/gv-procmime-Makefile.in.patch
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} `use_enable gnome gdk-pixbuf`"
+ myconf="${myconf} `use_enable imlib`"
+ myconf="${myconf} `use_enable spell aspell`"
+ myconf="${myconf} `use_enable ldap`"
+ myconf="${myconf} `use_enable ssl openssl`"
+ myconf="${myconf} `use_enable crypt gpgme`"
+ myconf="${myconf} `use_enable ipv6`"
+ myconf="${myconf} `use_enable pda jpilot`"
+ myconf="${myconf} `use_enable nls`"
+ myconf="${myconf} `use_enable dillo dillo-viewer-plugin`"
+ myconf="${myconf} `use_enable clamav clamav-plugin`"
+ myconf="${myconf} `use_enable xface compface`"
+
+ echo ${myconf}
+
+ econf \
+ --program-suffix=-claws \
+ --enable-spamassassin-plugin \
+ ${myconf} || die "./configure failed"
+
+ make || die
+
+ # build the extra tools
+ cd ${S}/tools
+ emake || die
+
+ # build the ghostscript-viewer plugin
+ if use pdflib; then
+ cd ${S2}
+ einfo "Compiling ghostscript-viewer plugin"
+ PKG_CONFIG_PATH=${S} \
+ CFLAGS="-I${S} -I${S}/src -I${S}/src/common -I${S}/src/gtk ${CFLAGS}" \
+ CXXFLAGS="${CFLAGS}" \
+ econf --with-sylpheed-dir=../.. || die
+
+ emake || die
+ fi
+
+ cd ${S}
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ local menuentry="/usr/share/gnome/apps/Internet/sylpheed.desktop"
+ if use gnome; then
+ dosed "s/Sylpheed/Sylpheed Claws/" ${menuentry}
+ dosed "s/sylpheed/sylpheed-claws/" ${menuentry}
+ mv ${D}${menuentry} ${D}${menuentry/sylpheed/sylpheed-claws}
+ else
+ rm -rf ${D}/usr/share/gnome
+ fi
+
+ dodir /usr/share/pixmaps
+ mv sylpheed.png ${D}/usr/share/pixmaps/sylpheed-claws.png
+
+ dodoc AUTHORS ChangeLog* INSTALL* NEWS README* TODO*
+ docinto tools
+ dodoc tools/README*
+
+ # install the extra tools
+ cd ${S}/tools
+ exeinto /usr/lib/${PN}/tools
+ doexe *.pl *.py *.rc *.conf gpg-sign-syl
+ doexe launch_firebird tb2sylpheed update-po uudec
+
+ # install the ghostscipt-viewer plugin
+ if use pdflib; then
+ cd ${S2}
+ make plugindir=${D}/usr/lib/${PN}/plugins install || die
+ docinto ${MY_GS}
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+ fi
+}