summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-21 20:24:27 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-21 20:24:27 +0000
commit228e80f9ebd6f874f3e8eb2d4bf4e7ac64896b0d (patch)
treee0b168c5d95ef016772a12eb3d3f3e7e6ef8398b /net-mail
parentMade changes to the c++ code to compile properly. It currently works on (diff)
downloadgentoo-2-228e80f9ebd6f874f3e8eb2d4bf4e7ac64896b0d.tar.gz
gentoo-2-228e80f9ebd6f874f3e8eb2d4bf4e7ac64896b0d.tar.bz2
gentoo-2-228e80f9ebd6f874f3e8eb2d4bf4e7ac64896b0d.zip
Version bump. No changes made to the ebuild. Please test and report on
bug #9340
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/fetchmail/ChangeLog9
-rw-r--r--net-mail/fetchmail/fetchmail-6.1.1.ebuild82
-rw-r--r--net-mail/fetchmail/files/digest-fetchmail-6.1.11
3 files changed, 91 insertions, 1 deletions
diff --git a/net-mail/fetchmail/ChangeLog b/net-mail/fetchmail/ChangeLog
index 2b554e4b858c..57039d3af561 100644
--- a/net-mail/fetchmail/ChangeLog
+++ b/net-mail/fetchmail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mailfetchmailChangeLog/
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.9 2002/10/10 11:21:55 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/ChangeLog,v 1.10 2002/10/21 20:24:27 raker Exp $
+
+*fetchmail-6.1.1 (21 Oct 2002)
+
+ 21 Oct 2002; Nick Hadaway <raker@gentoo.org> fetchmail-6.1.1.ebuild,
+ files/digest-fetchmail-6.1.1 :
+ Version bump. No ebuild changes required. Currently marked unstable
+ Please test and comment on bug #9340
*fetchmail-6.1.0 (01 Oct 2002)
diff --git a/net-mail/fetchmail/fetchmail-6.1.1.ebuild b/net-mail/fetchmail/fetchmail-6.1.1.ebuild
new file mode 100644
index 000000000000..47a90d877436
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.1.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/fetchmail/fetchmail-6.1.1.ebuild,v 1.1 2002/10/21 20:24:27 raker Exp $
+
+IUSE="ssl nls"
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="Fetchmail is a full-featured remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.tuxedo.org/~esr/fetchmail/"
+SRC_URI="http://www.tuxedo.org/~esr/fetchmail/${P}.tar.gz"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ nls? ( sys-devel/gettext )"
+
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="~x86"
+
+src_compile() {
+
+ local myconf
+
+ use ssl && myconf="${myconf} --with-ssl=/usr" \
+ || myconf="${myconf} --without-ssl"
+
+ use nls && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ # This needs inet6-apps, which we don't have
+ #use ipv6 && myconf="${myconf} --enable-inet6 --enable-netsec"
+ # || myconf="${myconf} --disable-inet6 --disable-netsec"
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ ${myconf} || die "Configuration failed."
+
+ emake || die "Compilation failed."
+
+}
+
+src_install() {
+
+ make DESTDIR="${D}" install || die
+
+ dohtml *.html
+
+ dodoc FAQ FEATURES ABOUT-NLS NEWS NOTES README \
+ README.NTLM README.SSL TODO COPYING MANIFEST
+
+ doman /usr/share/man/*.1
+ dosym /usr/share/man/fetchmailconf fetchmail.1
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/fetchmail
+
+ docinto contrib
+ local f
+ for f in contrib/*
+ do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+
+ if ! python -c "import Tkinter" >/dev/null 2>&1
+ then
+ einfo
+ einfo "You will not be able to use fetchmailconf(1), because you"
+ einfo "don't seem to have Python with tkinter support."
+ einfo
+ einfo "If you want to be able to use fetchmailconf(1), do the following:"
+ einfo " 1. Include 'tcltk' in USE variable in your /etc/make.conf."
+ einfo " 2. (Re-)merge Python."
+ einfo
+ fi
+
+}
diff --git a/net-mail/fetchmail/files/digest-fetchmail-6.1.1 b/net-mail/fetchmail/files/digest-fetchmail-6.1.1
new file mode 100644
index 000000000000..8942ee733e85
--- /dev/null
+++ b/net-mail/fetchmail/files/digest-fetchmail-6.1.1
@@ -0,0 +1 @@
+MD5 67c04b718a6ceebf58ef00ff96161706 fetchmail-6.1.1.tar.gz 1122485