summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-09-03 20:55:24 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-09-03 20:55:24 +0000
commita4932ee5aea581a8bb2b548beb13915b1164029e (patch)
treef02d304843082d932235d05179fbc36557bf1db9 /net-misc/gip/gip-1.1.0.1.ebuild
parentStable on ppc64 (diff)
downloadgentoo-2-a4932ee5aea581a8bb2b548beb13915b1164029e.tar.gz
gentoo-2-a4932ee5aea581a8bb2b548beb13915b1164029e.tar.bz2
gentoo-2-a4932ee5aea581a8bb2b548beb13915b1164029e.zip
bug 80540 and other fixes
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc/gip/gip-1.1.0.1.ebuild')
-rw-r--r--net-misc/gip/gip-1.1.0.1.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/net-misc/gip/gip-1.1.0.1.ebuild b/net-misc/gip/gip-1.1.0.1.ebuild
index f489db62760e..65e5af2ee3bb 100644
--- a/net-misc/gip/gip-1.1.0.1.ebuild
+++ b/net-misc/gip/gip-1.1.0.1.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gip/gip-1.1.0.1.ebuild,v 1.2 2004/07/08 23:41:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gip/gip-1.1.0.1.ebuild,v 1.3 2005/09/03 20:55:24 vanquirius Exp $
-MY_PV=`echo ${PV} | sed -e 's/.\([0-9]\+\)$/-\1/' 2>/dev/null`
-MY_P="${PN}-${MY_PV}"
-DESCRIPTION="a nice GNOME GUI for making IP address based calculations"
-HOMEPAGE="http://www.debain.org/?session=&site=2&project=19&cat=56"
+inherit versionator
+
+MY_P="${PN}-$(replace_version_separator 3 '-')"
+DESCRIPTION="A nice GNOME GUI for making IP address based calculations"
+HOMEPAGE="http://www.debain.org/software/gip/"
SRC_URI="http://web222.mis02.de/releases/gip/${MY_P}.tar.gz"
LICENSE="GPL-2"
@@ -13,17 +14,17 @@ SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="dev-cpp/gtkmm
- >=dev-libs/glib-2.2.3"
-#RDEPEND=""
+DEPEND="=dev-cpp/gtkmm-2.2*
+ >=dev-libs/glib-2.2.3
+ =dev-libs/libsigc++-1.2*"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_compile() {
./build.sh --prefix ${D}/usr || die "./build failed"
}
src_install() {
- dodoc AUTHORS COPYING INSTALL README
+ dodoc AUTHORS CHANGELOG INSTALL README
./build.sh --install --prefix ${D}/usr || die "./build --install failed"
}