summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2005-04-09 21:46:40 +0000
committerChristian Parpart <trapni@gentoo.org>2005-04-09 21:46:40 +0000
commit3e9196df339f296a38904714e572450a5619c74f (patch)
tree181df2a57a279e5bc0eaa1b22386de0756601704 /net-www
parentfix ownership on /etc/wwwoffle and /var/spool/wwwoffle (#88482) (diff)
downloadgentoo-2-3e9196df339f296a38904714e572450a5619c74f.tar.gz
gentoo-2-3e9196df339f296a38904714e572450a5619c74f.tar.bz2
gentoo-2-3e9196df339f296a38904714e572450a5619c74f.zip
adding blocks to apr and apr-util for obsolete apache2 ebuilds, so, that users wanting to upgrad are enforced to unmerge before they emerge the newer versions
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/ChangeLog9
-rw-r--r--net-www/apache/apache-2.0.50.ebuild8
-rw-r--r--net-www/apache/apache-2.0.51-r1.ebuild8
-rw-r--r--net-www/apache/apache-2.0.51.ebuild6
-rw-r--r--net-www/apache/apache-2.0.52-r1.ebuild6
-rw-r--r--net-www/apache/apache-2.0.52-r2.ebuild8
-rw-r--r--net-www/apache/apache-2.0.52.ebuild6
7 files changed, 35 insertions, 16 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index 6a89344c7ead..55135eed55ae 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/apache
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.337 2005/04/09 15:39:27 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.338 2005/04/09 21:46:40 trapni Exp $
+
+ 09 Apr 2005; Christian Parpart <trapni@gentoo.org> apache-2.0.50.ebuild,
+ apache-2.0.51.ebuild, apache-2.0.51-r1.ebuild, apache-2.0.52.ebuild,
+ apache-2.0.52-r1.ebuild, apache-2.0.52-r2.ebuild:
+ adding blocks to apr and apr-util for obsolete apache2 ebuilds, so, that
+ users wanting to upgrad are enforced to unmerge before they emerge the newer
+ versions
09 Apr 2005; Benedikt Boehm <hollow@gentoo.org> apache-1.3.33-r1.ebuild:
fixed dependency issues, see bug #86052 and mod_ssl changelog for details
diff --git a/net-www/apache/apache-2.0.50.ebuild b/net-www/apache/apache-2.0.50.ebuild
index 3c869ed463a5..3a22431b6f3c 100644
--- a/net-www/apache/apache-2.0.50.ebuild
+++ b/net-www/apache/apache-2.0.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.50.ebuild,v 1.19 2005/03/20 16:40:29 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.50.ebuild,v 1.20 2005/04/09 21:46:40 trapni Exp $
inherit flag-o-matic eutils fixheadtails gnuconfig
@@ -29,7 +29,9 @@ DEPEND="dev-util/yacc
berkdb? ( sys-libs/db )
gdbm? ( sys-libs/gdbm )
!mips? ( ldap? ( =net-nds/openldap-2* ) )
- selinux? ( sec-policy/selinux-apache )"
+ selinux? ( sec-policy/selinux-apache )
+ !dev-libs/apr
+ !dev-libs/apr-util"
apache_setup_vars() {
# Sets the USERDIR to default.
@@ -38,7 +40,7 @@ apache_setup_vars() {
einfo "USERDIR is set to: $USERDIR"
}
-set_filter_flags () {
+set_filter_flags() {
CFLAGS="${CFLAGS/ / }"
has_version =sys-libs/glibc-2.2* && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
}
diff --git a/net-www/apache/apache-2.0.51-r1.ebuild b/net-www/apache/apache-2.0.51-r1.ebuild
index beb9ed6b1dde..b77987ae6b4e 100644
--- a/net-www/apache/apache-2.0.51-r1.ebuild
+++ b/net-www/apache/apache-2.0.51-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.51-r1.ebuild,v 1.14 2005/03/20 16:40:29 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.51-r1.ebuild,v 1.15 2005/04/09 21:46:40 trapni Exp $
inherit flag-o-matic eutils fixheadtails gnuconfig
@@ -28,7 +28,9 @@ DEPEND="dev-util/yacc
berkdb? ( sys-libs/db )
gdbm? ( sys-libs/gdbm )
!mips? ( ldap? ( =net-nds/openldap-2* ) )
- selinux? ( sec-policy/selinux-apache )"
+ selinux? ( sec-policy/selinux-apache )
+ !dev-libs/apr
+ !dev-libs/apr-util"
apache_setup_vars() {
# Sets the USERDIR to default.
@@ -37,7 +39,7 @@ apache_setup_vars() {
einfo "USERDIR is set to: $USERDIR"
}
-set_filter_flags () {
+set_filter_flags() {
CFLAGS="${CFLAGS/ / }"
has_version =sys-libs/glibc-2.2* && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
}
diff --git a/net-www/apache/apache-2.0.51.ebuild b/net-www/apache/apache-2.0.51.ebuild
index 281de498c666..252d518ea197 100644
--- a/net-www/apache/apache-2.0.51.ebuild
+++ b/net-www/apache/apache-2.0.51.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.51.ebuild,v 1.16 2005/03/20 16:40:30 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.51.ebuild,v 1.17 2005/04/09 21:46:40 trapni Exp $
inherit flag-o-matic eutils fixheadtails gnuconfig
@@ -28,7 +28,9 @@ DEPEND="dev-util/yacc
berkdb? ( sys-libs/db )
gdbm? ( sys-libs/gdbm )
!mips? ( ldap? ( =net-nds/openldap-2* ) )
- selinux? ( sec-policy/selinux-apache )"
+ selinux? ( sec-policy/selinux-apache )
+ !dev-libs/apr
+ !dev-libs/apr-util"
apache_setup_vars() {
# Sets the USERDIR to default.
diff --git a/net-www/apache/apache-2.0.52-r1.ebuild b/net-www/apache/apache-2.0.52-r1.ebuild
index 64f3843534c4..584cb5a02b0d 100644
--- a/net-www/apache/apache-2.0.52-r1.ebuild
+++ b/net-www/apache/apache-2.0.52-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.52-r1.ebuild,v 1.16 2005/03/20 16:40:30 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.52-r1.ebuild,v 1.17 2005/04/09 21:46:40 trapni Exp $
inherit flag-o-matic eutils fixheadtails gnuconfig
@@ -29,7 +29,9 @@ DEPEND="dev-util/yacc
berkdb? ( sys-libs/db )
gdbm? ( sys-libs/gdbm )
!mips? ( ldap? ( =net-nds/openldap-2* ) )
- selinux? ( sec-policy/selinux-apache )"
+ selinux? ( sec-policy/selinux-apache )
+ !dev-libs/apr
+ !dev-libs/apr-util"
apache_setup_vars() {
# Sets the USERDIR to default.
diff --git a/net-www/apache/apache-2.0.52-r2.ebuild b/net-www/apache/apache-2.0.52-r2.ebuild
index c2d026c277a9..56db99e2382d 100644
--- a/net-www/apache/apache-2.0.52-r2.ebuild
+++ b/net-www/apache/apache-2.0.52-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.52-r2.ebuild,v 1.6 2005/03/20 16:40:30 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.52-r2.ebuild,v 1.7 2005/04/09 21:46:40 trapni Exp $
inherit flag-o-matic eutils fixheadtails gnuconfig
@@ -33,7 +33,9 @@ DEPEND="dev-util/yacc
berkdb? ( sys-libs/db )
gdbm? ( sys-libs/gdbm )
!mips? ( ldap? ( =net-nds/openldap-2* ) )
- selinux? ( sec-policy/selinux-apache )"
+ selinux? ( sec-policy/selinux-apache )
+ !dev-libs/apr
+ !dev-libs/apr-util"
PDEPEND="$DEPEND
php? ( dev-php/mod_php )"
@@ -45,7 +47,7 @@ apache_setup_vars() {
einfo "USERDIR is set to: $USERDIR"
}
-set_filter_flags () {
+set_filter_flags() {
CFLAGS="${CFLAGS/ / }"
has_version =sys-libs/glibc-2.2* && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
}
diff --git a/net-www/apache/apache-2.0.52.ebuild b/net-www/apache/apache-2.0.52.ebuild
index 356d22021bcb..c4b330800b88 100644
--- a/net-www/apache/apache-2.0.52.ebuild
+++ b/net-www/apache/apache-2.0.52.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.52.ebuild,v 1.14 2005/03/20 16:40:30 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.52.ebuild,v 1.15 2005/04/09 21:46:40 trapni Exp $
inherit flag-o-matic eutils fixheadtails gnuconfig
@@ -29,7 +29,9 @@ DEPEND="dev-util/yacc
berkdb? ( sys-libs/db )
gdbm? ( sys-libs/gdbm )
!mips? ( ldap? ( =net-nds/openldap-2* ) )
- selinux? ( sec-policy/selinux-apache )"
+ selinux? ( sec-policy/selinux-apache )
+ !dev-libs/apr
+ !dev-libs/apr-util"
apache_setup_vars() {
# Sets the USERDIR to default.