summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-11-30 09:59:41 +0000
committerChris White <chriswhite@gentoo.org>2005-11-30 09:59:41 +0000
commit452d5f75c3ad3754e34865c736497ee0ddb71331 (patch)
tree9d9056d6e6c1e92175e1401a23b215303b9b4f65 /sys-apps/pciutils/pciutils-2.1.11-r5.ebuild
parent*** empty log message *** (diff)
downloadgentoo-2-452d5f75c3ad3754e34865c736497ee0ddb71331.tar.gz
gentoo-2-452d5f75c3ad3754e34865c736497ee0ddb71331.tar.bz2
gentoo-2-452d5f75c3ad3754e34865c736497ee0ddb71331.zip
*** empty log message ***
Diffstat (limited to 'sys-apps/pciutils/pciutils-2.1.11-r5.ebuild')
-rw-r--r--sys-apps/pciutils/pciutils-2.1.11-r5.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild b/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild
index d67ebd40b8da..feba8370df8b 100644
--- a/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild
+++ b/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild,v 1.1 2005/06/12 21:17:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.1.11-r5.ebuild,v 1.1.1.1 2005/11/30 09:56:31 chriswhite Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -12,19 +12,21 @@ SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE=""
-DEPEND="virtual/libc"
+DEPEND=""
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
- epatch ${FILESDIR}/pcimodules-${P}.diff
- epatch ${FILESDIR}/${P}-sysfs.patch #38645
- epatch ${FILESDIR}/${P}-gentoo-paths.patch
- epatch ${FILESDIR}/${PV}-scan.patch #from fedora
+ epatch "${FILESDIR}"/pcimodules-${P}.diff
+ epatch "${FILESDIR}"/${P}-sysfs.patch #38645
+ epatch "${FILESDIR}"/${P}-gentoo-paths.patch
+ epatch "${FILESDIR}"/${PV}-scan.patch #from fedora
+ epatch "${FILESDIR}"/${P}-bsd.patch #103241
+ epatch "${FILESDIR}"/${P}-malloc.patch
# Unconditionally use -fPIC for libs (#55238)
# Make sure we respect $AR / $RANLIB / $CFLAGS
@@ -43,10 +45,11 @@ src_unpack() {
sed -i -e s/'rate\[8\]'/'rate\[9\]'/g lspci.c \
|| die "sed failed on lspci.c"
- ebegin "Updating pci.ids"
+ sed -i 's:wget -O:wget --connect-timeout=60 -O:' update-pciids.sh
+ ebegin "Updating pci.ids from the web"
if ! ./update-pciids.sh &> /dev/null ; then
# if we cant update, use a cached version
- mv ${WORKDIR}/pci.ids-${STAMP} ${S}/pci.ids
+ mv "${WORKDIR}"/pci.ids-${STAMP} "${S}"/pci.ids
fi
eend 0
}