summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-06 23:01:19 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-06 23:01:19 +0000
commit165d3c40af8050273ed9d8868b78431099e656bb (patch)
tree2934126efe7a4b71f5219f011c235b0871d3b7de /sys-devel/gcc-config
parentsync with reality (diff)
downloadgentoo-2-165d3c40af8050273ed9d8868b78431099e656bb.tar.gz
gentoo-2-165d3c40af8050273ed9d8868b78431099e656bb.tar.bz2
gentoo-2-165d3c40af8050273ed9d8868b78431099e656bb.zip
clean up the help output, add support for -v|--version and -h|--help options,
and then add the version to the gcc-config after installing
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/ChangeLog7
-rw-r--r--sys-devel/gcc-config/files/gcc-config-1.3.560
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.3-r1.ebuild4
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.3-r2.ebuild4
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.4.ebuild4
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.5.ebuild4
6 files changed, 40 insertions, 43 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 78c25337065d..8b61427571b9 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.40 2004/02/08 16:52:01 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.41 2004/05/06 23:01:19 vapier Exp $
+
+ 06 May 2004; Mike Frysinger <vapier@gentoo.org> files/gcc-config-1.3.5,
+ gcc-config-1.3.5.ebuild:
+ clean up the help output, add support for -v|--version and -h|--help options,
+ and then add the version to the gcc-config after installing
*gcc-config-1.3.5 (08 Feb 2004)
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.5 b/sys-devel/gcc-config/files/gcc-config-1.3.5
index 5aa35b0ef846..406425182c18 100644
--- a/sys-devel/gcc-config/files/gcc-config-1.3.5
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.5
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.5,v 1.2 2004/03/06 04:14:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.5,v 1.3 2004/05/06 23:01:19 vapier Exp $
# Author: Martin Schlemmer <azarah@gentoo.org>
source /etc/init.d/functions.sh || {
@@ -11,51 +11,35 @@ source /etc/init.d/functions.sh || {
usage() {
cat << "USAGE_END"
-Usage: gcc-config [Option] [CC Profile]
+Usage: gcc-config [options] [CC Profile]
Change the current cc/gcc profile, or give info about profiles.
Options:
- -O, --use-old
- Use the old profile if one was selected.
-
- -P, --use-portage-chost
- Only set to given profile if its CHOST is the same
- as that set for portage in /etc/make.conf (or one of
- other portage config files...).
-
- -c, --get-current-profile
- Print current used gcc profile.
+ -O, --use-old Use the old profile if one was selected.
- -l, --list-profiles
- Print a list of available profiles.
-
- -E, --print-environ
- Print environment that can be used to setup things
- for current gcc profile, or specified one ...
-
- -B, --get-bin-path
- Print path where binaries of given/current profile
- are located.
-
- -L, --get-lib-path
- Print path where libraries of given/current profile
- are located.
+ -P, --use-portage-chost Only set to given profile if its CHOST is the
+ same as that set for portage in /etc/make.conf
+ (or one of other portage config files...).
- -X, --get-stdcxx-incdir
- Print path to g++ include files of given/current
- profile.
-
-The profile name is in the form of:
+ -c, --get-current-profile Print current used gcc profile.
- <CHOST>-<gcc version>
+ -l, --list-profiles Print a list of available profiles.
-For example:
+ -E, --print-environ Print environment that can be used to setup the
+ current gcc profile, or a specified one.
- i686-pc-linux-gnu-3.2.1
+ -B, --get-bin-path Print path where binaries of the given/current
+ profile are located.
+ -L, --get-lib-path Print path where libraries of the given/current
+ profile are located.
+ -X, --get-stdcxx-incdir Print path where g++ include files of the
+ given/current profile are located.
+Profile names are of the form: <CHOST>-<gcc version>
+For example: i686-pc-linux-gnu-3.2.1
USAGE_END
exit 1
@@ -379,6 +363,14 @@ do
DOIT="get_stdcxx_incdir"
fi
;;
+ -h|--help)
+ usage
+ exit 0
+ ;;
+ -v|--version)
+ echo "gcc-config-PORTAGE-VERSION"
+ exit 0
+ ;;
-*)
eerror "$0: Invalid switch! Run $0 without parameters for help."
exit 1
diff --git a/sys-devel/gcc-config/gcc-config-1.3.3-r1.ebuild b/sys-devel/gcc-config/gcc-config-1.3.3-r1.ebuild
index a65d07dcb9b5..6bb083253c8c 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.3-r1.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.3-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.3-r1.ebuild,v 1.5 2004/02/23 00:21:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.3-r1.ebuild,v 1.6 2004/05/06 23:01:19 vapier Exp $
IUSE=""
diff --git a/sys-devel/gcc-config/gcc-config-1.3.3-r2.ebuild b/sys-devel/gcc-config/gcc-config-1.3.3-r2.ebuild
index 3abbf9dda0a9..d7ff639b8e9c 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.3-r2.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.3-r2.ebuild,v 1.1 2003/10/18 19:35:48 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.3-r2.ebuild,v 1.2 2004/05/06 23:01:19 vapier Exp $
IUSE=""
diff --git a/sys-devel/gcc-config/gcc-config-1.3.4.ebuild b/sys-devel/gcc-config/gcc-config-1.3.4.ebuild
index 792e57018601..300d124cfc1d 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.4.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.4.ebuild,v 1.3 2004/02/23 00:21:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.4.ebuild,v 1.4 2004/05/06 23:01:19 vapier Exp $
IUSE=""
diff --git a/sys-devel/gcc-config/gcc-config-1.3.5.ebuild b/sys-devel/gcc-config/gcc-config-1.3.5.ebuild
index 092ee8cac075..ded94b193744 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.5.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.5.ebuild,v 1.4 2004/04/24 07:56:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.5.ebuild,v 1.5 2004/05/06 23:01:19 vapier Exp $
W_VER="1.4.2"
@@ -61,10 +61,10 @@ src_install() {
else
newbin ${FILESDIR}/${PN}-${PV} ${PN}
fi
+ dosed "s:PORTAGE-VERSION:${PV}:" /usr/bin/${PN}
}
pkg_postinst() {
-
# Do we have a valid multi ver setup ?
if ${ROOT}/usr/bin/gcc-config --get-current-profile &> /dev/null
then