summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-01-28 18:32:06 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-01-28 18:32:06 +0000
commit08c32a0a1656225f5a20afa8048fa3f042ab9502 (patch)
tree4f522d89c336bfb91b04eef6a4a780784def472d /sys-devel
parentnew version; removed older (diff)
downloadgentoo-2-08c32a0a1656225f5a20afa8048fa3f042ab9502.tar.gz
gentoo-2-08c32a0a1656225f5a20afa8048fa3f042ab9502.tar.bz2
gentoo-2-08c32a0a1656225f5a20afa8048fa3f042ab9502.zip
new version
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/bison-1.32.ebuild55
-rw-r--r--sys-devel/bison/files/digest-bison-1.321
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-devel/bison/bison-1.32.ebuild b/sys-devel/bison/bison-1.32.ebuild
new file mode 100644
index 000000000000..a05c7d91277e
--- /dev/null
+++ b/sys-devel/bison/bison-1.32.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.32.ebuild,v 1.1 2002/01/28 18:32:06 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A yacc-compatible parser generator"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/bison/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --prefix=/usr \
+ --datadir=/usr/share \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ if [ -z "`use static`" ]
+ then
+ emake ${MAKEOPTS} || die
+ else
+ emake ${MAKEOPTS} LDFLAGS=-static || die
+ fi
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ datadir=${D}/usr/share \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING AUTHORS NEWS ChangeLog README REFERENCES OChangeLog
+ docinto txt
+ dodoc doc/FAQ
+ else
+ rm -rf ${D}/usr/share/man ${D}/usr/share/info
+ fi
+}
+
diff --git a/sys-devel/bison/files/digest-bison-1.32 b/sys-devel/bison/files/digest-bison-1.32
new file mode 100644
index 000000000000..d7e9556910b1
--- /dev/null
+++ b/sys-devel/bison/files/digest-bison-1.32
@@ -0,0 +1 @@
+MD5 e82867ca1ca34623dc83bbf22ed23a86 bison-1.32.tar.gz 729088