summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-05-17 13:22:33 +0000
committerTravis Tilley <lv@gentoo.org>2004-05-17 13:22:33 +0000
commit832a9fc82035c23bf8242b363605760c34159ba4 (patch)
treee66f22e9e8648dd9a062c40b9d45ced6ce621a47 /sys-libs/glibc
parentAdd two patches for KDE security update (Manifest recommit) (diff)
downloadgentoo-2-832a9fc82035c23bf8242b363605760c34159ba4.tar.gz
gentoo-2-832a9fc82035c23bf8242b363605760c34159ba4.tar.bz2
gentoo-2-832a9fc82035c23bf8242b363605760c34159ba4.zip
added fix for compiling the new frandom ssp.c with gcc 3.4
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/files/2.3.3/glibc-2.3.3-ssp-gcc34-after-frandom.patch19
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040420-r1.ebuild7
3 files changed, 31 insertions, 2 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 8aaf5b31e63e..d834f52e444a 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.154 2004/05/14 22:06:41 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.155 2004/05/17 13:22:33 lv Exp $
+
+ 17 May 2004; Travis Tilley <lv@gentoo.org>
+ +files/2.3.3/glibc-2.3.3-ssp-gcc34-after-frandom.patch,
+ glibc-2.3.3_pre20040420-r1.ebuild:
+ added fix for compiling SSP with gcc 3.4
*glibc-2.3.3_pre20040420-r1 (14 May 2004)
diff --git a/sys-libs/glibc/files/2.3.3/glibc-2.3.3-ssp-gcc34-after-frandom.patch b/sys-libs/glibc/files/2.3.3/glibc-2.3.3-ssp-gcc34-after-frandom.patch
new file mode 100644
index 000000000000..dd863869c04a
--- /dev/null
+++ b/sys-libs/glibc/files/2.3.3/glibc-2.3.3-ssp-gcc34-after-frandom.patch
@@ -0,0 +1,19 @@
+--- ./sysdeps/unix/sysv/linux/ssp.c.old 2004-05-17 06:46:31.000000000 -0400
++++ ./sysdeps/unix/sysv/linux/ssp.c 2004-05-17 07:46:42.264773000 -0400
+@@ -44,9 +44,15 @@
+ #define SSP_SIGTYPE SIGABRT
+ #endif
+
++#if __GNUC__ > 3 || (__GNUC__ == 3 && __GNUC_MINOR__ >= 3)
++#define __attribute_used__ __attribute__((__used__))
++#else
++#define __attribute_used__ __attribute__((__unused__))
++#endif
++
+ unsigned long __guard = 0UL;
+
+-void
++__attribute_used__ void __attribute__ ((visibility ("default")))
+ __guard_setup (void)
+ {
+ size_t size;
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040420-r1.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040420-r1.ebuild
index 148ced128f0f..8263a21c4762 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040420-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040420-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040420-r1.ebuild,v 1.1 2004/05/14 22:06:41 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040420-r1.ebuild,v 1.2 2004/05/17 13:22:33 lv Exp $
IUSE="nls pic build nptl erandom"
@@ -284,6 +284,11 @@ src_unpack() {
epatch ${FILESDIR}/2.3.3/${LOCAL_P}-propolice-guard-functions-v3.patch
cp ${FILESDIR}/2.3.3/ssp.c ${S}/sysdeps/unix/sysv/linux || \
die "failed to copy ssp.c to ${S}/sysdeps/unix/sysv/linux/"
+ # gcc 3.4 nukes ssp without this patch
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ then
+ epatch ${FILESDIR}/2.3.3/glibc-2.3.3-ssp-gcc34-after-frandom.patch
+ fi
fi
# patch this regardless of architecture, although it's ssp-related