summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-11-30 09:49:41 +0000
committerChris White <chriswhite@gentoo.org>2005-11-30 09:49:41 +0000
commit14afc7ac4f63d55e776e6880f47f1c635021b0cc (patch)
treec935d59c46497de060f501912e5e27df91538d54 /sys-process/procps/procps-3.2.5-r1.ebuild
parent(no commit message) (diff)
downloadgentoo-2-14afc7ac4f63d55e776e6880f47f1c635021b0cc.tar.gz
gentoo-2-14afc7ac4f63d55e776e6880f47f1c635021b0cc.tar.bz2
gentoo-2-14afc7ac4f63d55e776e6880f47f1c635021b0cc.zip
*** empty log message ***
Diffstat (limited to 'sys-process/procps/procps-3.2.5-r1.ebuild')
-rw-r--r--sys-process/procps/procps-3.2.5-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-process/procps/procps-3.2.5-r1.ebuild b/sys-process/procps/procps-3.2.5-r1.ebuild
index 2062ea912874..49098a637061 100644
--- a/sys-process/procps/procps-3.2.5-r1.ebuild
+++ b/sys-process/procps/procps-3.2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/procps-3.2.5-r1.ebuild,v 1.1 2005/03/03 16:53:14 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/procps-3.2.5-r1.ebuild,v 1.1.1.1 2005/11/30 09:49:06 chriswhite Exp $
inherit flag-o-matic eutils toolchain-funcs
@@ -10,14 +10,14 @@ SRC_URI="http://procps.sf.net/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE="n32"
RDEPEND=">=sys-libs/ncurses-5.2-r2"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# Fix terminal breakage when sorting first column in top #80296
epatch "${FILESDIR}"/${PV}-top-sort.patch
@@ -31,21 +31,22 @@ src_unpack() {
-e '/install/s: --strip : :' \
-e '/ALL_CFLAGS += $(call check_gcc,-fweb,)/d' \
-e '/ALL_CFLAGS += $(call check_gcc,-Wstrict-aliasing=2,)/s,=2,,' \
+ -e "/^lib64/s:=.*:=$(get_libdir):" \
Makefile || die "sed Makefile"
use ppc && sed -i -e 's:-m64::g' Makefile
# mips patches
- if use mips; then
+ if use mips ; then
# mips 2.4.23 headers (and 2.6.x) don't allow PAGE_SIZE to be defined in
# userspace anymore, so this patch instructs procps to get the
# value from sysconf().
- epatch ${FILESDIR}/${PN}-mips-define-pagesize.patch
+ epatch "${FILESDIR}"/${PN}-mips-define-pagesize.patch
# n32 isn't completly reliable of an ABI on mips64 at the current
# time. Eventually, it will be, but for now, we need to make sure
# procps doesn't try to force it on us.
- if ! use n32; then
- epatch ${FILESDIR}/${PN}-mips-n32_isnt_usable_on_mips64_yet.patch
+ if ! use n32 ; then
+ epatch "${FILESDIR}"/${PN}-mips-n32_isnt_usable_on_mips64_yet.patch
fi
fi
}
@@ -53,7 +54,6 @@ src_unpack() {
src_compile() {
replace-flags -O3 -O2
emake \
- lib64="$(get_libdir)" \
CC="$(tc-getCC)" \
CPPFLAGS="${CPPFLAGS}" \
CFLAGS="${CFLAGS}" \