summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gpgme/gpgme-1.0.2.ebuild')
-rw-r--r--app-crypt/gpgme/gpgme-1.0.2.ebuild30
1 files changed, 22 insertions, 8 deletions
diff --git a/app-crypt/gpgme/gpgme-1.0.2.ebuild b/app-crypt/gpgme/gpgme-1.0.2.ebuild
index 30ea748ea069..3f2dac50a085 100644
--- a/app-crypt/gpgme/gpgme-1.0.2.ebuild
+++ b/app-crypt/gpgme/gpgme-1.0.2.ebuild
@@ -1,18 +1,16 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-1.0.2.ebuild,v 1.1 2005/01/12 15:05:06 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-1.0.2.ebuild,v 1.1.1.1 2005/11/30 09:44:57 chriswhite Exp $
-inherit eutils
+inherit eutils libtool
DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
HOMEPAGE="http://www.gnupg.org/(en)/related_software/gpgme/index.html"
-SRC_URI="ftp://ftp.gnupg.org/gcrypt/gpgme/${P}.tar.gz"
-
-#SRC_URI="mirror://gnu/gcrypt/gpgme/${P}.tar.gz"
+SRC_URI="mirror://gnupg/gpgme/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="1"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64 ~ppc64"
+KEYWORDS="alpha amd64 hppa ia64 mips ppc ~ppc-macos ppc64 sparc x86"
IUSE=""
#IUSE="smime"
@@ -21,7 +19,7 @@ DEPEND=">=app-crypt/gnupg-1.2.2
sys-devel/libtool
sys-devel/gcc
>=dev-libs/libgpg-error-0.5
- !ia64? ( dev-libs/pth )"
+ !mips? ( dev-libs/pth )"
# For when gnupg-1.9+ gets unmasked
# !smime? ( >=app-crypt/gnupg-1.2.2 )
@@ -31,12 +29,24 @@ RDEPEND="virtual/libc
>=dev-libs/libgpg-error-0.5
dev-libs/libgcrypt
>=app-crypt/gnupg-1.2.2
- !ia64? ( dev-libs/pth )"
+ !mips? ( dev-libs/pth )"
src_compile() {
+ if use ppc-macos; then
+ sed -i \
+ -e "s:AC_PREREQ(2.59):#AC_PREREQ(2.59):" \
+ -e "s:min_automake_version="1.9.3":#min_automake_version="1.9.3":" \
+ configure.ac || die
+ libtoolize --force --copy
+ aclocal
+ fi
+
WANT_AUTOCONF=2.57
autoconf || die "failed to autoconfigure"
+ if use ppc-macos; then
+ automake || die "failed to automake"
+ fi
if [ -x /usr/bin/gpg2 ]; then
GPGBIN=/usr/bin/gpg2
@@ -47,6 +57,10 @@ src_compile() {
# For when gnupg-1.9+ gets unmasked
# $(use_with smime gpgsm /usr/bin/gpgsm) \
+ if use selinux; then
+ sed -i -e "s:tests = tests:tests = :" Makefile.in || die
+ fi
+
econf \
--includedir=/usr/include/gpgme \
--with-gpg=$GPGBIN \