summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/qca/qca-1.0-r2.ebuild')
-rw-r--r--app-crypt/qca/qca-1.0-r2.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/app-crypt/qca/qca-1.0-r2.ebuild b/app-crypt/qca/qca-1.0-r2.ebuild
index fc6d959a5b57..1a1c8240fa76 100644
--- a/app-crypt/qca/qca-1.0-r2.ebuild
+++ b/app-crypt/qca/qca-1.0-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-1.0-r2.ebuild,v 1.1 2005/01/24 18:02:19 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-1.0-r2.ebuild,v 1.1.1.1 2005/11/30 09:44:49 chriswhite Exp $
-inherit eutils
+inherit eutils qt3
DESCRIPTION="Qt Cryptographic Architecture (QCA)"
HOMEPAGE="http://delta.affinix.com/qca/"
@@ -10,17 +10,17 @@ SRC_URI="http://delta.affinix.com/qca/qca-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 x86 sparc ppc ~ia64 ~hppa ~alpha"
-IUSE=""
+KEYWORDS="alpha amd64 hppa ia64 mips ppc ppc64 sparc x86"
+IUSE="ssl"
-DEPEND=">=x11-libs/qt-3.3.0-r1"
-
-RDEPEND=" ssl? ( app-crypt/qca-tls ) "
+DEPEND="$(qt_min_version 3.3.0)"
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/qca-pathfix.patch || die "bad patch"
+ epatch ${FILESDIR}/qca-pathfix.patch
+ #This is needed just in bsd, but make no harm in linux
+ epatch ${FILESDIR}/qca-1.0-fbsd.patch
}
src_compile() {