summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/abiword/abiword-1.99.5.ebuild')
-rw-r--r--app-office/abiword/abiword-1.99.5.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/app-office/abiword/abiword-1.99.5.ebuild b/app-office/abiword/abiword-1.99.5.ebuild
index 03d8c45d7be1..88fd80af6445 100644
--- a/app-office/abiword/abiword-1.99.5.ebuild
+++ b/app-office/abiword/abiword-1.99.5.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.99.5.ebuild,v 1.2 2003/08/27 16:49:47 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.99.5.ebuild,v 1.3 2003/09/06 22:21:01 msterret Exp $
inherit eutils debug
IUSE="spell jpeg xml2 gnome"
S=${WORKDIR}/${P}/abi
-# REMIND : usually -${PV} needs to be added
+# REMIND : usually -${PV} needs to be added
S_P=${WORKDIR}/${PN}-plugins
DESCRIPTION="Fully featured yet light and fast cross platform word processor"
@@ -32,8 +32,8 @@ RDEPEND="virtual/x11
jpeg? ( >=media-libs/jpeg-6b-r2 )
( xml2? >=dev-libs/libxml2-2.4.10 : dev-libs/expat )
spell? ( >=app-text/enchant-0.1 )
- gnome? ( >=gnome-base/libgnomeui-2.2
- >=gnome-base/libgnomeprintui-2.2.1
+ gnome? ( >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libgnomeprintui-2.2.1
>=gnome-extra/gal-1.99 )"
DEPEND="${RDEPEND}
@@ -48,7 +48,7 @@ src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/${P}-cast_fix.patch
+ epatch ${FILESDIR}/${P}-cast_fix.patch
}
@@ -58,8 +58,8 @@ src_compile() {
# this is a hack since I don't want to go hack in the gnome-vfs headerfiles.
# The issue is about gnome-vfs containing "long long" which makes gcc 3.3.1 balk
cp configure configure.old
- cat configure.old |sed s:-pedantic::g >configure
- rm -f configure.old
+ cat configure.old |sed s:-pedantic::g >configure
+ rm -f configure.old
econf \
`use_enable gnome` \
@@ -68,7 +68,7 @@ src_compile() {
--enable-bidi \
--without-ImageMagick \
--disable-scripting \
- --with-sys-wv || die
+ --with-sys-wv || die
emake all-recursive || die
@@ -82,13 +82,13 @@ src_compile() {
}
-src_install() {
+src_install() {
dodir /usr/{bin,lib}
-
+
einstall PERLDEST=${D} || die
-
+
dosed "s:${D}::g" /usr/bin/AbiWord-2.0
-
+
rm -f ${D}/usr/bin/abiword-2.0
rm -f ${D}/usr/bin/abiword
dosym AbiWord-2.0 /usr/bin/abiword-2.0