summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/openoffice/openoffice-1.1_rc3.ebuild')
-rw-r--r--app-office/openoffice/openoffice-1.1_rc3.ebuild36
1 files changed, 18 insertions, 18 deletions
diff --git a/app-office/openoffice/openoffice-1.1_rc3.ebuild b/app-office/openoffice/openoffice-1.1_rc3.ebuild
index 48a05f79334d..133ce679869a 100644
--- a/app-office/openoffice/openoffice-1.1_rc3.ebuild
+++ b/app-office/openoffice/openoffice-1.1_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1_rc3.ebuild,v 1.1 2003/08/20 07:57:01 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.1_rc3.ebuild,v 1.2 2003/09/06 22:21:02 msterret Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -134,7 +134,7 @@ pkg_setup() {
eerror "you could do the following:"
eerror
eerror " # export FORCE_JAVA=yes"
- eerror
+ eerror
die
fi
@@ -225,7 +225,7 @@ oo_setup() {
export GCC_PROFILE="$(/usr/sbin/gcc-config --get-current-profile)"
# Just recheck gcc version ...
- if [ "$(gcc-version)" != "3.2" ]
+ if [ "$(gcc-version)" != "3.2" ]
then
# See if we can get a gcc profile we know is proper ...
if /usr/sbin/gcc-config --get-bin-path ${CHOST}-3.2.1 &> /dev/null
@@ -333,8 +333,8 @@ src_compile() {
export CC="/usr/bin/ccache/ccache ${CC}"
export CXX="/usr/bin/ccache/ccache ${CXX}"
fi
-
- # Enable new ccache for this build
+
+ # Enable new ccache for this build
if [ "${FEATURES/-ccache/}" = "${FEATURES}" -a \
"${FEATURES/ccache/}" != "${FEATURES}" -a \
-x /usr/bin/ccache ]
@@ -344,7 +344,7 @@ src_compile() {
export CC="/usr/bin/ccache ${CC}"
export CXX="/usr/bin/ccache ${CXX}"
fi
-
+
# Enable distcc for this build (Az)
if [ "${FEATURES/-distcc/}" = "${FEATURES}" -a \
"${FEATURES/distcc/}" != "${FEATURES}" -a \
@@ -369,10 +369,10 @@ src_compile() {
--with-jdk-home=${JAVA_HOME} \
--with-lang=${LANGNAME}\
--with-x || die
-
+
cd ${S}
get_EnvSet
-
+
# Do not include /usr/include in header search path, and
# same thing for internal gcc include dir, as gcc3 handles
# it correctly by default! (Az)
@@ -404,7 +404,7 @@ src_compile() {
# Set CCCOMP and CXXCOMP. This is still needed for STLport
echo "setenv CCCOMP \"${CC}\"" >> ${S}/${LinuxEnvSet}
echo "setenv CXXCOMP \"${CXX}\"" >> ${S}/${LinuxEnvSet}
- fi
+ fi
if [ "$(gcc-major-version)" -eq 3 ]
then
@@ -454,7 +454,7 @@ src_install() {
addpredict "/share"
addpredict "/dev/dri"
addpredict "/usr/bin/soffice"
- addpredict "/pspfontcache"
+ addpredict "/pspfontcache"
# This allows us to change languages without editing the ebuild.
#
@@ -468,7 +468,7 @@ src_install() {
set_languages
get_EnvSet
-
+
# The install part should now be relatively OK compared to
# what it was. Basically we use autoresponse files to install
# unattended, running under a Xvfb if needed. Afterwards we
@@ -491,7 +491,7 @@ src_install() {
[JAVA]
JavaSupport=preinstalled_or_none
END_RS
-
+
# Autoresponse file for user isntallation
cat > ${T}/rsfile-local <<-"END_RS"
[ENVIRONMENT]
@@ -541,7 +541,7 @@ src_install() {
insinto /etc/openoffice
sed -e "s|<pv>|${PV//_rc3/.0}|g" ${T}/rsfile-local > ${T}/autoresponse-${PV}.conf
doins ${T}/autoresponse-${PV}.conf
-
+
# Install wrapper script
exeinto /usr/bin
sed -e "s|<pv>|${PV}|g" \
@@ -564,7 +564,7 @@ src_install() {
# Install the files needed for the catagory
doins ${D}${INSTDIR}/share/gnome/net/.directory
doins ${D}${INSTDIR}/share/gnome/net/.order
-
+
for x in ${D}${INSTDIR}/share/gnome/net/*.desktop
do
# We have to handle setup differently
@@ -578,14 +578,14 @@ src_install() {
if [ -n "`use kde`" ]
then
local kdeloc="${D}${INSTDIR}/share/kde/net/"
-
+
insinto /usr/share/applnk/OpenOffice.org\ 1.1
# Install the files needed for the catagory
doins ${kdeloc}/.directory
dodir /usr/share
# Install the icons and mime info
cp -a ${D}${INSTDIR}/share/kde/net/share/mimelnk ${D}${INSTDIR}/share/kde/net/share/icons ${D}/usr/share
-
+
for x in ${kdeloc}/*.desktop
do
# We have to handle setup differently
@@ -624,7 +624,7 @@ pkg_postinst() {
einfo
einfo " If the fonts appear garbled in the user interface refer to "
einfo " Bug 8539, or http://www.openoffice.org/FAQs/fontguide.html#8"
- einfo
+ einfo
einfo "******************************************************************"
-}
+}