summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gnome-vfsmm/gnome-vfsmm-2.6.1.ebuild')
-rw-r--r--dev-cpp/gnome-vfsmm/gnome-vfsmm-2.6.1.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.6.1.ebuild b/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.6.1.ebuild
index 25f5afc9ddae..21d34bc72f1d 100644
--- a/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.6.1.ebuild
+++ b/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.6.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.6.1.ebuild,v 1.1 2004/05/09 15:52:40 khai Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.6.1.ebuild,v 1.1.1.1 2005/11/30 09:46:21 chriswhite Exp $
inherit gnome2
@@ -10,8 +10,8 @@ HOMEPAGE="http://gtkmm.sourceforge.net/"
IUSE=""
LICENSE="LGPL-2.1"
-KEYWORDS="~x86"
-SLOT="1.0"
+KEYWORDS="amd64 ppc ppc64 sparc x86 hppa"
+SLOT="1.1"
RDEPEND=">=gnome-base/gnome-vfs-2.6
>=dev-cpp/glibmm-2.4"
@@ -20,3 +20,14 @@ DEPEND=">=dev-util/pkgconfig-0.12.0
${RDEPEND}"
DOCS="AUTHORS COPYING* ChangeLog NEWS README INSTALL"
+
+src_compile() {
+ if useq amd64 || useq ppc64; then
+ aclocal -I scripts
+ automake -c -f
+ autoconf
+ libtoolize --copy --force
+ fi
+
+ gnome2_src_compile
+}