summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-net/commons-net-1.3.0-r1.ebuild')
-rw-r--r--dev-java/commons-net/commons-net-1.3.0-r1.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/dev-java/commons-net/commons-net-1.3.0-r1.ebuild b/dev-java/commons-net/commons-net-1.3.0-r1.ebuild
index 4a87ac038148..941469b358b3 100644
--- a/dev-java/commons-net/commons-net-1.3.0-r1.ebuild
+++ b/dev-java/commons-net/commons-net-1.3.0-r1.ebuild
@@ -1,22 +1,23 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.3.0-r1.ebuild,v 1.1 2005/03/29 15:35:45 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.3.0-r1.ebuild,v 1.1.1.1 2005/11/30 09:47:34 chriswhite Exp $
inherit eutils java-pkg
DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions."
HOMEPAGE="http://jakarta.apache.org/commons/net/"
SRC_URI="mirror://apache/jakarta/commons/net/source/${P}-src.tar.gz"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/jakarta-oro-2.0"
DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-core-1.5.4
- >=dev-java/jakarta-oro-2.0*
junit? ( dev-java/junit )
jikes? ( dev-java/jikes )
- source? ( app-arch/zip )"
-RDEPEND=">=virtual/jre-1.3"
+ source? ( app-arch/zip )
+ ${RDEPEND}"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~amd64 ~ppc64"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64 ppc64"
IUSE="doc examples jikes junit source"
S=${WORKDIR}/${P}-src
@@ -31,12 +32,10 @@ src_unpack() {
cd ${S}
if ! use junit ; then
- sed -i 's/depends="compile,test"/depends="compile"/' \
- build.xml || die "Failed to disable junit"
+ sed -i 's/depends="compile,test"/depends="compile"/' build.xml || die "Failed to disable junit"
else
if ! has_version dev-java/ant-tasks; then
- sed -i 's/depends="compile,test"/depends="compile"/' \
- build.xml || die "Failed to disable junit"
+ sed -i 's/depends="compile,test"/depends="compile"/' build.xml || die "Failed to disable junit"
fi
fi
}
@@ -49,8 +48,7 @@ src_compile() {
}
src_install() {
- mv ${S}/target/${P}-dev.jar ${S}/target/${PN}.jar
- java-pkg_dojar target/${PN}.jar
+ java-pkg_newjar target/${P}-dev.jar ${PN}.jar
use doc && java-pkg_dohtml -r dist/docs/
if use examples; then