summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/commons-pool/commons-pool-1.1.ebuild')
-rw-r--r--dev-java/commons-pool/commons-pool-1.1.ebuild59
1 files changed, 27 insertions, 32 deletions
diff --git a/dev-java/commons-pool/commons-pool-1.1.ebuild b/dev-java/commons-pool/commons-pool-1.1.ebuild
index 96c7d5cb9a3e..de6e3450e881 100644
--- a/dev-java/commons-pool/commons-pool-1.1.ebuild
+++ b/dev-java/commons-pool/commons-pool-1.1.ebuild
@@ -1,50 +1,45 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.1.ebuild,v 1.1 2004/01/21 05:14:43 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-pool/commons-pool-1.1.ebuild,v 1.1.1.1 2005/11/30 09:47:37 chriswhite Exp $
+
+inherit java-pkg
-S=${WORKDIR}/${PN}-${PV}
DESCRIPTION="Jakarta-Commons component providing general purpose object pooling API"
-HOMEPAGE="http://jakarta.apache.org/commons/pool.html"
-SRC_URI="mirror://apache/jakarta/commons/pool/source/${PN}-${PV}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4
- >=dev-java/commons-collections-2.0
- junit? ( >=junit-3.7 )"
+HOMEPAGE="http://jakarta.apache.org/commons/pool/"
+SRC_URI="mirror://apache/jakarta/commons/pool/source/${P}-src.tar.gz"
RDEPEND=">=virtual/jre-1.3
>=dev-java/commons-collections-2.0"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ ${RDEPEND}
+ junit? ( >=dev-java/junit-3.7 )
+ jikes? ( dev-java/jikes )"
LICENSE="Apache-1.1"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc amd64"
-IUSE="jikes junit"
+KEYWORDS="x86 ppc sparc amd64"
+IUSE="jikes junit doc"
-src_compile() {
- local myc
+src_unpack() {
+ unpack ${A}
cd ${S}
- echo "commons-collections.jar=`java-config --classpath=commons-collections`" > build.properties
-
- if [ -n "`use jikes`" ] ; then
- myc="${myc} -Dbuild.compiler=jikes"
- fi
-
- if [ -n "`use junit`" ] ; then
- echo "junit.jar=`java-config --classpath=junit`" >> build.properties
- ANT_OPTS=${myc} ant || die "Testing Classes Failed"
- fi
+ echo "commons-collections.jar=$(java-pkg_getjars commons-collections)" > build.properties
+ use junit && echo "junit.jar=$(java-pkg_getjars junit)" >> build.properties
+}
- ANT_OPTS=${myc} ant dist || die "Compilation Failed"
+src_compile() {
+ local antflags="dist"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use junit && antflags="${antflags} test"
+ use doc && antflags="${antflags} javadoc"
- if [ -n "`use doc`" ] ; then
- ANT_OPTS=${myc} ant javadoc || die "Unable to create documents"
- fi
+ ant ${antflags} || die "Compilation Failed"
}
-src_install () {
- dojar dist/${PN}*.jar || die "Unable to install"
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
dodoc README.txt
dohtml STATUS.html PROPOSAL.html
- if [ -n "`use doc`" ] ; then
- dohtml -r dist/docs/*
- fi
+ use doc && java-pkg_dohtml -r dist/docs/*
}