summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/joscar/joscar-0.9.3.ebuild')
-rw-r--r--dev-java/joscar/joscar-0.9.3.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-java/joscar/joscar-0.9.3.ebuild b/dev-java/joscar/joscar-0.9.3.ebuild
index 2b5c1d6c657e..5d03224d641a 100644
--- a/dev-java/joscar/joscar-0.9.3.ebuild
+++ b/dev-java/joscar/joscar-0.9.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/joscar/joscar-0.9.3.ebuild,v 1.1 2004/02/22 01:51:47 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/joscar/joscar-0.9.3.ebuild,v 1.1.1.1 2005/11/30 09:47:23 chriswhite Exp $
inherit java-pkg
@@ -10,11 +10,11 @@ HOMEPAGE="http://joust.kano.net/joscar"
SLOT="0"
LICENSE="BSD"
-KEYWORDS="~x86 ~sparc"
+KEYWORDS="x86 ~sparc amd64"
IUSE="jikes doc"
DEPEND=">=virtual/jdk-1.4
- >=dev-java/ant-1.5
+ >=dev-java/ant-core-1.5
jikes? ( >=dev-java/jikes-1.16 )"
RDEPEND=">=virtual/jre-1.4"
@@ -22,11 +22,11 @@ src_compile() {
local antflags="jar"
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
use doc && antflags="${antflags} javadoc"
- ant ${antflags}
+ ant ${antflags} || die "compilation problem"
}
src_install() {
- java-pkg_dojar *.jar
+ java-pkg_newjar ${P}-bin.jar ${PN}.jar
dodoc USING CHANGELOG UPDATING README RELNOTES
- use doc && dohtml -r docs/api
+ use doc && java-pkg_dohtml -r docs/api
}