summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/erlang/erlang-10.2.0.ebuild')
-rw-r--r--dev-lang/erlang/erlang-10.2.0.ebuild44
1 files changed, 36 insertions, 8 deletions
diff --git a/dev-lang/erlang/erlang-10.2.0.ebuild b/dev-lang/erlang/erlang-10.2.0.ebuild
index 1a8338ebf9c6..6b9ecbbea484 100644
--- a/dev-lang/erlang/erlang-10.2.0.ebuild
+++ b/dev-lang/erlang/erlang-10.2.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-10.2.0.ebuild,v 1.1 2004/10/08 00:03:02 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-10.2.0.ebuild,v 1.1.1.1 2005/11/30 09:58:45 chriswhite Exp $
-inherit eutils gcc flag-o-matic
+inherit eutils toolchain-funcs flag-o-matic elisp-common
#erlang uses a really weird versioning scheme which caused quite a few problems already
#Thus we do a slight modification converting all letters to digits to make it more sane (see e.g. #26420)
@@ -17,27 +17,40 @@ SRC_URI="http://www.erlang.org/download/${MY_P}-0.tar.gz"
LICENSE="EPL"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~amd64"
-IUSE="X ssl"
+IUSE="X ssl emacs"
DEPEND=">=dev-lang/perl-5.6.1
X? ( virtual/x11 )
- ssl? ( >=dev-libs/openssl-0.9.6d )"
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ emacs? ( virtual/emacs )"
S=${WORKDIR}/${MY_P}_${MyDate}
+SITEFILE=50erlang-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-10.2.6-export-TARGET.patch
+}
+
src_compile() {
[ "`gcc-fullversion`" == "3.3.2" ] && filter-mfpmath sse
[ "`gcc-fullversion`" == "3.3.3" ] && filter-mfpmath sse
addpredict /dev/pty # Bug #25366
- #erlang configure seems to "misdetect" CHOST on amd64
- [ "${ARCH}" = "amd64" ] && CHOST="x86_64-unknown-linux-gnu"
econf --enable-threads || die
make || die
+
+ if use emacs; then
+ pushd ${D}/lib/tools/emacs
+ elisp-compile *.el
+ popd
+ fi
}
src_install() {
- ERL_LIBDIR="/usr/lib/erlang"
+ ERL_LIBDIR="/usr/$(get_libdir)/erlang"
make INSTALL_PREFIX=${D} install || die
dodoc AUTHORS EPLICENCE README
@@ -57,4 +70,19 @@ src_install() {
## Clean up the no longer needed files
rm ${D}/${ERL_LIBDIR}/Install
+
+ if use emacs; then
+ pushd ${S}
+ elisp-install erlang lib/tools/emacs/*.el
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ popd
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
}