summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/icon/icon-9.40.ebuild')
-rw-r--r--dev-lang/icon/icon-9.40.ebuild95
1 files changed, 45 insertions, 50 deletions
diff --git a/dev-lang/icon/icon-9.40.ebuild b/dev-lang/icon/icon-9.40.ebuild
index 0145f2f4f51d..cbde7b0a284a 100644
--- a/dev-lang/icon/icon-9.40.ebuild
+++ b/dev-lang/icon/icon-9.40.ebuild
@@ -1,64 +1,59 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icon/icon-9.40.ebuild,v 1.1 2001/07/31 22:51:49 danarmak Exp $
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icon/icon-9.40.ebuild,v 1.1.1.1 2005/11/30 09:58:06 chriswhite Exp $
-S=${WORKDIR}/icon.v940src
-SRC_URI="http://www.cs.arisona.edu/icon/ftp/packages/unix/icon.v940src.tgz"
+MY_PV=${PV/./}
+SRC_URI="http://www.cs.arizona.edu/icon/ftp/packages/unix/icon.v${MY_PV}src.tgz"
+HOMEPAGE="http://www.cs.arizona.edu/icon/"
+DESCRIPTION="very high level language"
-HOMEPAGE="http://www.cs.arisona.edu/icon/"
-DESCRIPTION="icon is a v. high level language"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 sparc ~amd64"
+IUSE="X"
+
+S=${WORKDIR}/icon.v${MY_PV}src
DEPEND="X? ( virtual/x11 )
sys-devel/gcc"
src_unpack() {
-
- cd ${WORKDIR}
- unpack ${A}
- cd ${S}/config/unix/intel_linux
- patch -p0 <${FILESDIR}/${P}-gentoo.diff
-
+ unpack ${A}
+ cd ${S}/config/unix/intel_linux
+ patch -p0 <${FILESDIR}/${P}-gentoo.diff
}
src_compile() {
-
- cd ${S}
+ if use X; then
+ make X-Configure name=intel_linux || die
+ else
+ make Configure name=intel_linux || die
+ fi
+
+ make || die
+
+ # small builtin test
+ make Samples || die
+ # large builtin test
+ make Test || die
+}
- if [ "`use X`" ]; then
- try make X-Configure name=intel_linux
- else
- try make Configure name=intel_linux
- fi
-
- try make
-
- # small builtin test
- try make Samples
- # large builtin test
- try make Test
+src_install() {
+ #make Install dest=${D}/opt/icon || die
+ # fhs-problems, manual rectify
+ into /usr
-}
+ cd ${S}/bin
+ rm .placeholder libXpm.a rt.h
+ dobin *
+
+ cd ${S}/lib
+ rm .placeholder
+ dolib *
+
+ cd ${S}/man/man1
+ doman icont.1
-src_install () {
-
- #try make Install dest=${D}/opt/icon
- # fhs-problems, manual rectify
-
- into /usr
-
- cd ${S}/bin
- rm .placeholder libXpm.a rt.h
- dobin *
-
- cd ${S}/lib
- rm .placeholder
- dolib *
-
- cd ${S}/man/man1
- doman icont.1
-
- cd ${S}/doc
- dodoc * ../README
-
+ cd ${S}/doc
+ dodoc * ../README
}