summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/ocaml/ocaml-3.07-r1.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild62
1 files changed, 55 insertions, 7 deletions
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
index ba021cf23ddd..a92236db02cc 100644
--- a/dev-lang/ocaml/ocaml-3.07-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.1 2003/10/16 19:24:18 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.1.1.1 2005/11/30 09:58:37 chriswhite Exp $
inherit flag-o-matic eutils
-filter-flags "-fstack-protector"
DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
@@ -13,20 +12,31 @@ SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha"
-IUSE="tcltk"
+KEYWORDS="x86 sparc ppc alpha ~ia64 ~amd64 hppa ~ppc-macos"
+IUSE="tcltk latex"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
tcltk? ( >=dev-lang/tk-3.3.3 )"
+pkg_setup() {
+ ewarn
+ ewarn "Building ocaml with unsafe CFLAGS can have unexpected results"
+ ewarn "Please retry building with safer CFLAGS before reporting bugs"
+ ewarn
+}
+
src_unpack() {
- unpack ${A}
+ unpack ${P}.tar.gz
cd ${S}
+ use hppa && epatch ${FILESDIR}/${P}-hppa.patch
epatch ${DISTDIR}/${P}-patch2.diffs
grep -rle "head -1" . | xargs sed -i "s:head -1:head -n 1:g"
}
src_compile() {
+ filter-flags "-fstack-protector"
+ replace-flags "-O?" -O2
+
local myconf
use tcltk || myconf="-no-tk"
@@ -35,12 +45,18 @@ src_compile() {
myconf="${myconf} -host sparc-unknown-linux-gnu"
fi
+ # Fix for bug #46703
+ export LC_ALL=C
+
./configure -prefix /usr \
-bindir /usr/bin \
-libdir /usr/lib/ocaml \
-mandir /usr/share/man \
--with-pthread ${myconf} || die
+ sed -i -e "s/\(BYTECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
+ sed -i -e "s/\(NATIVECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
+
make world || die
make opt || die
make opt.opt || die
@@ -58,3 +74,35 @@ src_install() {
# documentation
dodoc Changes INSTALL LICENSE README Upgrading
}
+
+pkg_postinst() {
+ ranlib /usr/lib/ocaml/libasmrunp.a
+ ranlib /usr/lib/ocaml/libbigarray.a
+ ranlib /usr/lib/ocaml/libcamlrun.a
+ ranlib /usr/lib/ocaml/libgraphics.a
+ ranlib /usr/lib/ocaml/libmldbm.a
+ ranlib /usr/lib/ocaml/libnums.a
+ ranlib /usr/lib/ocaml/libstr.a
+ ranlib /usr/lib/ocaml/libthreads.a
+ ranlib /usr/lib/ocaml/libthreadsnat.a
+ ranlib /usr/lib/ocaml/libunix.a
+ ranlib /usr/lib/ocaml/libstr.a
+ ranlib /usr/lib/ocaml/str.a
+ ranlib /usr/lib/ocaml/unix.a
+ ranlib /usr/lib/ocaml/stdlib.a
+ ranlib /usr/lib/ocaml/libasmrun.a
+
+
+ if use latex; then
+ echo "TEXINPUTS=/usr/lib/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
+ fi
+
+ echo
+ einfo "OCaml is not binary compatible from version to version,"
+ einfo "so you (may) need to rebuild all packages depending on it that"
+ einfo "are actually installed on your system."
+ einfo "To do so, you can run: "
+ einfo "sh ${FILESDIR}/ocaml-rebuild.sh [-h | emerge options]"
+ einfo "Which will call emerge on all old packages with the given options"
+ echo
+}