summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/swi-prolog-lite/swi-prolog-lite-5.3.14.ebuild')
-rw-r--r--dev-lang/swi-prolog-lite/swi-prolog-lite-5.3.14.ebuild49
1 files changed, 27 insertions, 22 deletions
diff --git a/dev-lang/swi-prolog-lite/swi-prolog-lite-5.3.14.ebuild b/dev-lang/swi-prolog-lite/swi-prolog-lite-5.3.14.ebuild
index cd4c0b657578..66ccf65671d4 100644
--- a/dev-lang/swi-prolog-lite/swi-prolog-lite-5.3.14.ebuild
+++ b/dev-lang/swi-prolog-lite/swi-prolog-lite-5.3.14.ebuild
@@ -1,40 +1,45 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog-lite/swi-prolog-lite-5.3.14.ebuild,v 1.1 2004/07/13 05:06:14 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog-lite/swi-prolog-lite-5.3.14.ebuild,v 1.1.1.1 2005/11/30 09:58:36 chriswhite Exp $
-IUSE="readline static"
+inherit eutils
-S="${WORKDIR}/pl-${PV}"
DESCRIPTION="free, small, and standard compliant Prolog compiler"
HOMEPAGE="http://www.swi-prolog.org/"
-SRC_URI="http://www.swi.psy.uva.nl/cgi-bin/nph-download/SWI-Prolog/BETA/pl-5.3.14.tar.gz"
+SRC_URI="http://www.swi.psy.uva.nl/cgi-bin/nph-download/SWI-Prolog/BETA/pl-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="macos"
+KEYWORDS="~amd64 ppc-macos ~x86"
+IUSE="readline static threads"
DEPEND="sys-libs/ncurses
- sys-apps/gawk
- sys-apps/sed
- virtual/libc
readline? ( sys-libs/readline )"
-src_compile() {
- cd ${S}/src
- #S="${S}/src"
-
- local myconf
- use readline || myconf="${myconf} --disable-readline"
- use static && myconf="${myconf} --disable-shared"
+S=${WORKDIR}/pl-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/src
+ epatch "${FILESDIR}"/destdir.patch
+ epatch "${FILESDIR}"/${P}-parallel-build.patch
+ sed -i \
+ -e '/COFLAGS=/s:=.*:=$CFLAGS:' \
+ -e '/LDFLAGS=/s:-O3::' \
+ configure || die
+}
- econf ${myconf} --enable-mt || die "econf failed"
- MAKEOPTS="-j1" emake || die "make failed"
+src_compile() {
+ cd src
+ econf \
+ $(use_enable readline) \
+ $(use_enable !static shared) \
+ $(use_enable threads mt) \
+ || die "econf failed"
+ emake || die "make failed"
}
src_install() {
- cd ${S}/src
- einstall
-
- cd ${S}
+ make -C src DESTDIR="${D}" install || die
dodoc ANNOUNCE ChangeLog INSTALL INSTALL.notes PORTING README VERSION
}