summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild')
-rw-r--r--dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild b/dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild
index 323a950b1469..edef18024b4b 100644
--- a/dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild
+++ b/dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild
@@ -1,26 +1,27 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild,v 1.1 2005/05/11 05:29:30 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-4.3.11-r1.ebuild,v 1.1.1.1 2005/11/30 09:47:52 chriswhite Exp $
PHPSAPI="cgi"
inherit php-sapi eutils
DESCRIPTION="PHP CGI"
SLOT="0"
-KEYWORDS="x86 sparc alpha hppa ppc ia64 amd64 ~mips"
+IUSE="force-cgi-redirect"
+KEYWORDS="alpha amd64 hppa ia64 mips ppc sparc x86"
# for this revision only
PDEPEND=">=${PHP_PROVIDER_PKG}-4.3.11"
-PROVIDE="${PROVIDE} virtual/httpd-php-${PV}"
+PROVIDE="${PROVIDE} virtual/httpd-php"
src_unpack() {
php-sapi_src_unpack
# Bug 88756
- use flash && epatch ${FILESDIR}/php-4.3.11-flash.patch
+ use flash && epatch "${FILESDIR}/php-4.3.11-flash.patch"
# Bug 88795
- use gmp && epatch ${FILESDIR}/php-4.3.11-gmp.patch
+ use gmp && epatch "${FILESDIR}/php-4.3.11-gmp.patch"
}
src_compile() {
@@ -28,8 +29,11 @@ src_compile() {
myconf="${myconf} \
--enable-cgi \
--enable-cli \
- --enable-fastcgi \
- --enable-force-cgi-redirect"
+ --enable-fastcgi"
+
+ if use force-cgi-redirect; then
+ myconf="${myconf} --enable-force-cgi-redirect"
+ fi
php-sapi_src_compile
}
@@ -38,9 +42,9 @@ src_install() {
PHP_INSTALLTARGETS="install"
php-sapi_src_install
- rm -f ${D}/usr/bin/php
+ rm -f "${D}/usr/bin/php"
# rename binary
- newbin ${S}/sapi/cgi/php php-cgi
+ newbin "${S}/sapi/cgi/php" php-cgi
}
pkg_postinst() {