summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/smarty/smarty-2.6.5.ebuild')
-rw-r--r--dev-php/smarty/smarty-2.6.5.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-php/smarty/smarty-2.6.5.ebuild b/dev-php/smarty/smarty-2.6.5.ebuild
index 4f707cfdf81a..1889fa663e16 100644
--- a/dev-php/smarty/smarty-2.6.5.ebuild
+++ b/dev-php/smarty/smarty-2.6.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.5.ebuild,v 1.1 2004/09/26 16:26:15 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.6.5.ebuild,v 1.1.1.1 2005/11/30 09:47:57 chriswhite Exp $
MY_P=Smarty-${PV}
DESCRIPTION="A template engine for PHP"
@@ -8,7 +8,7 @@ HOMEPAGE="http://smarty.php.net/"
SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~hppa ~ppc ~sparc ~x86"
+KEYWORDS="alpha hppa ~ppc sparc x86 ~amd64"
IUSE="doc"
DEPEND="doc? ( dev-php/smarty-docs )"
RDEPEND="virtual/php"
@@ -17,12 +17,14 @@ S=${WORKDIR}/${MY_P}
src_install() {
dodoc [A-Z]*
mkdir -p ${D}/usr/lib/php
- cp -a libs ${D}/usr/lib/php/Smarty
+ cp -pPR libs ${D}/usr/lib/php/Smarty
}
pkg_postinst() {
einfo "Smarty has been installed in /usr/lib/php/Smarty/."
einfo "To use it in your scripts, either"
einfo "1. define('SMARTY_DIR', \"/usr/lib/php/Smarty/\") in your scripts, or"
- einfo "2. add /usr/lib/php/Smarty/ to includes= in /etc/php4/php.ini"
+ einfo "2. add '/usr/lib/php/Smarty/' to the 'include_path' variable in your"
+ einfo "php.ini file under /etc/php/SAPI (where SAPI is one of apache-php[45],"
+ einfo "cgi-php[45] or cli-php[45])."
}