summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/drpython/drpython-3.10.13.ebuild')
-rw-r--r--dev-python/drpython/drpython-3.10.13.ebuild25
1 files changed, 6 insertions, 19 deletions
diff --git a/dev-python/drpython/drpython-3.10.13.ebuild b/dev-python/drpython/drpython-3.10.13.ebuild
index d498fd9df96c..95a154c8dc7b 100644
--- a/dev-python/drpython/drpython-3.10.13.ebuild
+++ b/dev-python/drpython/drpython-3.10.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/drpython-3.10.13.ebuild,v 1.4 2005/08/09 21:20:20 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/drpython-3.10.13.ebuild,v 1.1 2005/05/04 02:22:37 pythonhead Exp $
inherit eutils distutils
@@ -9,9 +9,10 @@ HOMEPAGE="http://drpython.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~x86"
IUSE=""
-RDEPEND=">=dev-python/wxpython-2.6"
+RDEPEND="virtual/python
+ >=dev-python/wxpython-2.5.3.1"
DEPEND="app-arch/unzip"
src_unpack() {
@@ -21,23 +22,9 @@ src_unpack() {
}
src_install() {
- distutils_python_version
-
- local destdir="/usr/lib/python${PYVER}/site-packages/${PN}/"
- dodir ${destdir}/bitmaps/{16,24}
- cp -R bitmaps ${D}/${destdir} || die "Failed to cp bitmaps"
-
distutils_src_install
-
- #Windows-only setup script:
- rm ${D}/usr/bin/postinst.py
-
- echo -e "#!/bin/sh\n\npython ${destdir}/drpython.py \$@" > drpython
+ distutils_python_version
+ echo -e "#!/bin/sh\n\npython /usr/lib/python${PYVER}/site-packages/drpython/drpython.py \$@" > drpython
dobin drpython
}
-pkg_postinst() {
- einfo "See the DrPython homepage for 20+ available plugins:"
- einfo "http://sourceforge.net/project/showfiles.php?group_id=83074"
-}
-