summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tclx/tclx-8.3.ebuild')
-rw-r--r--dev-tcltk/tclx/tclx-8.3.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-tcltk/tclx/tclx-8.3.ebuild b/dev-tcltk/tclx/tclx-8.3.ebuild
index 46a88e2df7a3..225648e58f47 100644
--- a/dev-tcltk/tclx/tclx-8.3.ebuild
+++ b/dev-tcltk/tclx/tclx-8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.3.ebuild,v 1.11 2004/04/14 11:32:38 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclx/tclx-8.3.ebuild,v 1.12 2004/04/26 01:42:31 agriffis Exp $
inherit flag-o-matic eutils
@@ -33,7 +33,7 @@ src_unpack() {
src_compile() {
# we have to configure and build tcl before we can do tclx
cd ${WORKDIR}/tcl8.3.3/unix
- econf
+ econf || die "econf failed"
emake CFLAGS="${CFLAGS}" || die "emake in tcl/unix failed"
local myconf="--with-tcl=${WORKDIR}/tcl8.3.3/unix --enable-shared"
@@ -41,7 +41,7 @@ src_compile() {
if [ `use X` ] ; then
# configure and build tk
cd ${WORKDIR}/tk8.3.3/unix
- econf
+ econf || die "econf failed"
emake CFLAGS="${CFLAGS}" || die
myconf="${myconf} --with-tk=${WORKDIR}/tk8.3.3/unix"
else
@@ -50,7 +50,7 @@ src_compile() {
# configure and build tclx
cd ${S}/unix
- econf ${myconf}
+ econf ${myconf} || die "econf failed"
make CFLAGS="${CFLAGS}" || die
}