summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cunit/cunit-1.0.0.8.ebuild')
-rw-r--r--dev-util/cunit/cunit-1.0.0.8.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/cunit/cunit-1.0.0.8.ebuild b/dev-util/cunit/cunit-1.0.0.8.ebuild
new file mode 100644
index 000000000000..c05fd71f1ead
--- /dev/null
+++ b/dev-util/cunit/cunit-1.0.0.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/cunit-1.0.0.8.ebuild,v 1.1 2003/05/15 14:45:11 phosphan Exp $
+
+S=${WORKDIR}/CUnit-1.0-8
+DESCRIPTION="CUnit - C Unit Test Framework"
+# Note: Upstream authors have sucky versioning scheme. We fake.
+SRC_URI="mirror://sourceforge/cunit/CUnit-1.0-8.tar.gz"
+HOMEPAGE="http://cunit.sourceforge.net"
+
+DEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86 sparc"
+
+src_compile() {
+ ./configure --prefix=/usr || die "configure failed"
+ make || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS COPYING INSTALL NEWS README ChangeLog
+}