summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'eclass/gnustep-old.eclass')
-rw-r--r--eclass/gnustep-old.eclass49
1 files changed, 22 insertions, 27 deletions
diff --git a/eclass/gnustep-old.eclass b/eclass/gnustep-old.eclass
index b9982b7ed705..b003574e5ceb 100644
--- a/eclass/gnustep-old.eclass
+++ b/eclass/gnustep-old.eclass
@@ -1,14 +1,12 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gnustep-old.eclass,v 1.1 2004/07/22 20:39:44 fafhrd Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gnustep-old.eclass,v 1.1.1.1 2005/11/30 09:59:33 chriswhite Exp $
-ECLASS=gnustep
-INHERITED="$INHERITED $ECLASS"
DESCRIPTION="Based on the gnustep eclass."
-DEPEND="dev-util/gnustep-make
- dev-util/gnustep-base
+DEPEND="gnustep-base/gnustep-make
+ gnustep-base/gnustep-base
sys-devel/gcc
virtual/libc"
RDEPEND="virtual/libc"
@@ -27,11 +25,11 @@ getsourcedir() {
need-gnustep-gui() {
if [ "$1" ] ; then
- DEPEND="${DEPEND} >=dev-util/gnustep-gui-$1"
- RDEPEND="${RDEPEND} >=dev-util/gnustep-back-$1"
+ DEPEND="${DEPEND} >=gnustep-base/gnustep-gui-$1"
+ RDEPEND="${RDEPEND} >=gnustep-base/gnustep-back-$1"
else
- DEPEND="${DEPEND} dev-util/gnustep-gui"
- RDEPEND="${RDEPEND} dev-util/gnustep-back"
+ DEPEND="${DEPEND} gnustep-base/gnustep-gui"
+ RDEPEND="${RDEPEND} gnustep-base/gnustep-back"
fi
}
@@ -39,13 +37,10 @@ egnustepmake() {
getsourcedir
addwrite /root/GNUstep/Defaults/.GNUstepDefaults.lck
- addpredict /root/GNUstep
+ addpredict /root/GNUstep
cd ${S}
- unset CFLAGS
- unset CC
-
if [ -f /usr/GNUstep/System/Makefiles/GNUstep.sh ] ; then
. /usr/GNUstep/System/Makefiles/GNUstep.sh
else
@@ -78,7 +73,7 @@ egnustepmake() {
fi
fi
fi
-
+
if [ -f ./[mM]akefile -o -f ./GNUmakefile ] ; then
make \
HOME=$TMP/fakehome \
@@ -94,15 +89,15 @@ egnustepinstall() {
getsourcedir
addwrite /root/GNUstep/Defaults/.GNUstepDefaults.lck
- addpredict /root/GNUstep
+ addpredict /root/GNUstep
cd ${S}
-
+
if [ -f /usr/GNUstep/System/Makefiles/GNUstep.sh ] ; then
- source /usr/GNUstep/System/Makefiles/GNUstep.sh
- else
- die "gnustep-make not installed!"
- fi
+ source /usr/GNUstep/System/Makefiles/GNUstep.sh
+ else
+ die "gnustep-make not installed!"
+ fi
mkdir -p $TMP/fakehome/GNUstep
@@ -111,7 +106,7 @@ egnustepinstall() {
# Should all the roots point at GNUSTEP_SYSTEM_ROOT to force
# install?
# GNUSTEP_USER_ROOT must be GNUSTEP_SYSTEM_ROOT, some malformed
- # Makefiles install there.
+ # Makefiles install there.
if [ "${PN}" = "gnustep-base" ] || [ "${PN}" = "gnustep-gui" ] || [ "${PN}" = "gnustep-back" ] ; then
# for some reason, they need less tending to...
make \
@@ -120,12 +115,12 @@ egnustepinstall() {
GNUSTEP_INSTALLATION_DIR=${D}${GNUSTEP_SYSTEM_ROOT} \
INSTALL_ROOT_DIR=${D} \
install || die "einstall failed"
- else
+ else
make \
GNUSTEP_USER_ROOT=$TMP/fakehome/GNUstep \
HOME=$TMP/fakehome \
- GNUSTEP_INSTALLATION_DIR=${D}${GNUSTEP_SYSTEM_ROOT} \
- INSTALL_ROOT_DIR=${D} \
+ GNUSTEP_INSTALLATION_DIR=${D}${GNUSTEP_SYSTEM_ROOT} \
+ INSTALL_ROOT_DIR=${D} \
GNUSTEP_LOCAL_ROOT=${D}${GNUSTEP_LOCAL_ROOT} \
GNUSTEP_NETWORK_ROOT=${D}${GNUSTEP_NETWORK_ROOT} \
GNUSTEP_SYSTEM_ROOT=${D}${GNUSTEP_SYSTEM_ROOT} \
@@ -133,16 +128,16 @@ egnustepinstall() {
install || die "einstall failed"
fi
else
- die "no Makefile found"
+ die "no Makefile found"
fi
return 0
}
-gnustep_src_compile() {
+gnustep-old_src_compile() {
egnustepmake || die
}
-gnustep_src_install() {
+gnustep-old_src_install() {
egnustepinstall || die
}