summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/frotz/frotz-2.43.ebuild')
-rw-r--r--games-engines/frotz/frotz-2.43.ebuild34
1 files changed, 21 insertions, 13 deletions
diff --git a/games-engines/frotz/frotz-2.43.ebuild b/games-engines/frotz/frotz-2.43.ebuild
index 89aaa477e86a..05ead2d69120 100644
--- a/games-engines/frotz/frotz-2.43.ebuild
+++ b/games-engines/frotz/frotz-2.43.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/frotz/frotz-2.43.ebuild,v 1.1 2003/09/09 17:34:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/frotz/frotz-2.43.ebuild,v 1.1.1.1 2005/11/30 09:46:26 chriswhite Exp $
+
+inherit toolchain-funcs games
DESCRIPTION="Curses based interpreter for Z-code based text games"
HOMEPAGE="http://www.cs.csubak.edu/~dgriffi/proj/frotz/"
@@ -8,24 +10,30 @@ SRC_URI="http://www.ifarchive.org/if-archive/infocom/interpreters/frotz/${P}.tar
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc"
-IUSE="oss alsa"
+KEYWORDS="amd64 ppc ppc-macos x86"
+IUSE="alsa oss"
DEPEND="sys-libs/ncurses
alsa? ( oss? ( media-libs/alsa-oss ) )"
src_compile() {
- local MAKE_OPTS="CONFIG_DIR=/etc"
- use oss && MAKE_OPTS="${MAKE_OPTS} SOUND_DEFS=-DOOS_SOUND"
- emake ${MAKE_OPTS} || die
+ local OPTS="CC=$(tc-getcc) CONFIG_DIR=${GAMES_SYSCONFDIR}"
+ use oss && OPTS="${MAKE_OPTS} SOUND_DEFS=-DOSS_SOUND SOUND_DEV=/dev/dsp"
+ emake ${MAKE_OPTS} all || die "emake failed"
}
src_install () {
- into /usr
- dobin frotz
- doman frotz.6
- dodoc AUTHORS BUGS COPYING ChangeLog HOW_TO_PLAY INSTALL NOTES README TODO
+ dogamesbin {d,}frotz || die "dogamesbin failed"
+ doman doc/*.6
+ dodoc AUTHORS BUGS ChangeLog HOW_TO_PLAY README TODO \
+ doc/{frotz.conf-big,frotz.conf-small}
+ prepgamesdirs
+}
- insinto /usr/share/${P}/
- doins frotz.conf-big frotz.conf-small
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "Global config file can be installed in ${GAMES_SYSCONFDIR}/frotz.conf"
+ einfo "Sample config files are in /usr/share/doc/${PF}"
+ echo
}