summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/gargoyle/gargoyle-2011.1.ebuild')
-rw-r--r--games-engines/gargoyle/gargoyle-2011.1.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/games-engines/gargoyle/gargoyle-2011.1.ebuild b/games-engines/gargoyle/gargoyle-2011.1.ebuild
index 5fa453eaf751..2255b3c62325 100644
--- a/games-engines/gargoyle/gargoyle-2011.1.ebuild
+++ b/games-engines/gargoyle/gargoyle-2011.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-2011.1.ebuild,v 1.3 2012/06/15 15:40:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/gargoyle/gargoyle-2011.1.ebuild,v 1.4 2012/08/21 19:18:49 hasufell Exp $
# Regarding licenses: libgarglk is licensed under the GPLv2. Bundled
# interpreters are licensed under GPLv2, BSD or MIT license, except:
@@ -10,7 +10,7 @@
# don't apply. (Fonts are installed through dependencies instead.)
EAPI=3
-inherit eutils multiprocessing games
+inherit eutils multiprocessing toolchain-funcs games
DESCRIPTION="An Interactive Fiction (IF) player supporting all major formats"
HOMEPAGE="http://ccxvii.net/gargoyle/"
@@ -33,7 +33,8 @@ RDEPEND="media-libs/freetype:2
DEPEND="${RDEPEND}
app-arch/unzip
- dev-util/ftjam"
+ dev-util/ftjam
+ virtual/pkgconfig"
src_prepare() {
# Substitute custom CFLAGS/LDFLAGS.
@@ -52,13 +53,17 @@ src_prepare() {
# The font name of Linux Libertine changed in version 5.
sed -i -e 's/Linux Libertine O/Linux Libertine/g' garglk/garglk.ini
+
+ epatch "${FILESDIR}"/${P}-desktopfile.patch
}
src_compile() {
jam \
+ -sAR="$(tc-getAR) cru" \
-sGARGLKINI="${GAMES_SYSCONFDIR}/garglk.ini" \
-sUSESDL=yes \
-sBUNDLEFONTS=no \
+ -dx \
-j$(makeopts_jobs) || die
}