summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/ffmpeg/ffmpeg-0.4.8.ebuild')
-rw-r--r--media-video/ffmpeg/ffmpeg-0.4.8.ebuild35
1 files changed, 16 insertions, 19 deletions
diff --git a/media-video/ffmpeg/ffmpeg-0.4.8.ebuild b/media-video/ffmpeg/ffmpeg-0.4.8.ebuild
index 16065039e7a3..7f8a568052b1 100644
--- a/media-video/ffmpeg/ffmpeg-0.4.8.ebuild
+++ b/media-video/ffmpeg/ffmpeg-0.4.8.ebuild
@@ -1,35 +1,27 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.8.ebuild,v 1.1 2003/10/18 19:30:27 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-0.4.8.ebuild,v 1.1.1.1 2005/11/30 09:57:55 chriswhite Exp $
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="Complete solution to record, convert and stream audio and video. Includes libavcodec."
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
HOMEPAGE="http://ffmpeg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-IUSE="mmx encode oggvorbis doc faad dvd static sdl imlib truetype"
-
-inherit flag-o-matic
-filter-flags "-fforce-addr -fPIC"
-# fixes bug #16281
-use alpha && append-flags "-fPIC"
-
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+SLOT="0"
+KEYWORDS="~x86 ppc ~sparc alpha amd64 ia64 arm ~mips hppa"
+IUSE="altivec debug doc dvd encode aac imlib mmx oggvorbis sdl static truetype"
DEPEND="encode? ( >=media-sound/lame-3.92 )
oggvorbis? ( >=media-libs/libvorbis-1.0-r1 )
doc? ( >=app-text/texi2html-1.64 )
- faad? ( >=media-libs/faad2-1.1 )
+ aac? ( >=media-libs/faad2-1.1 )
dvd? ( >=media-libs/a52dec-0.7.4 )
sdl? ( >=media-libs/libsdl-1.2.5 )
imlib? ( >=media-libs/imlib2-1.0.6 )
truetype? ( >=media-libs/freetype-2.1.2 )"
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${A} || die
cd ${S}
@@ -37,20 +29,26 @@ src_unpack() {
# for some reason it tries to #include <X11/Xlib.h>,b ut doesn't use it
cd ${S}
sed -i s:\#define\ HAVE_X11:\#define\ HAVE_LINUX: ffplay.c
-
}
src_compile() {
+ filter-flags -fforce-addr -fPIC
+ # fixes bug #16281
+ use alpha && append-flags -fPIC
+ use amd64 && append-flags -fPIC
+ use hppa && append-flags -fPIC
+
local myconf
myconf="${myconf} --disable-opts --enable-pp"
use mmx || myconf="${myconf} --disable-mmx"
use encode && myconf="${myconf} --enable-mp3lame"
use oggvorbis && myconf="${myconf} --enable-vorbis"
- use faad && myconf="${myconf} --enable-faad --enable-faadbin"
+ use aac && myconf="${myconf} --enable-faad --enable-faadbin"
use dvd && myconf="${myconf} --enable-a52 --enable-a52bin"
use static || myconf="${myconf} --enable-shared"
use sdl || myconf="${myconf} --disable-ffplay"
use debug || myconf="${myconf} --disable-debug"
+ use altivec || myconf="${myconf} --disable-altivec"
./configure ${myconf} \
--prefix=/usr || die "./configure failed."
@@ -59,7 +57,6 @@ src_compile() {
}
src_install() {
-
make \
DESTDIR=${D} \
prefix=${D}/usr \